{"id":"CVE-2026-18245","state":"PUBLISHED","title":"Incomplete fix for CVE-2025-4318 code injection in Amazon @aws-amplify/codegen-ui-react","description":"Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318.\n\n\n\nTo remediate this issue, users should upgrade to version 2.20.6","publishedAt":"2026-07-30T18:13:07.047Z","updatedAt":"2026-07-30T19:15:12.776Z","severity":{"score":6.4,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","source":"AMZN"},"assigner":"AMZN","products":["AWS Amplify Codegen UI"],"affected":[{"vendor":"AWS","product":"Amplify Codegen UI","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"2.20.6","versionType":"custom"}]}],"references":["https://github.com/aws-amplify/amplify-codegen-ui/releases/tag/v2.20.6","https://aws.amazon.com/security/security-bulletins/2026-066-aws/","https://github.com/aws-amplify/amplify-codegen-ui/security/advisories/GHSA-74xx-rjgf-m69j"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:11:10.572Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/18xxx/CVE-2026-18245.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-18245","state":"PUBLISHED","datePublished":"2026-07-30T18:13:07.047Z","dateUpdated":"2026-07-30T19:15:12.776Z","assignerShortName":"AMZN","assignerOrgId":"ff89ba41-3aa1-4d27-914a-91399e9639e5","dateReserved":"2026-07-29T14:45:04.539Z"},"containers":{"cna":{"title":"Incomplete fix for CVE-2025-4318 code injection in Amazon @aws-amplify/codegen-ui-react","descriptions":[{"lang":"en","value":"Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318.\n\n\n\nTo remediate this issue, users should upgrade to version 2.20.6"}],"affected":[{"vendor":"AWS","product":"Amplify Codegen UI","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"2.20.6","versionType":"custom"}]}],"references":[{"url":"https://github.com/aws-amplify/amplify-codegen-ui/releases/tag/v2.20.6","tags":["patch"]},{"url":"https://aws.amazon.com/security/security-bulletins/2026-066-aws/","tags":["vendor-advisory"]},{"url":"https://github.com/aws-amplify/amplify-codegen-ui/security/advisories/GHSA-74xx-rjgf-m69j","tags":["third-party-advisory"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"LOW","userInteraction":"REQUIRED","scope":"CHANGED","confidentialityImpact":"HIGH","integrityImpact":"HIGH","availabilityImpact":"HIGH","baseSeverity":"CRITICAL","baseScore":9,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H"}},{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"LOW","userInteraction":"PASSIVE","vulnConfidentialityImpact":"NONE","subConfidentialityImpact":"HIGH","vulnIntegrityImpact":"NONE","subIntegrityImpact":"HIGH","vulnAvailabilityImpact":"NONE","subAvailabilityImpact":"HIGH","exploitMaturity":"NOT_DEFINED","Safety":"NOT_DEFINED","Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","valueDensity":"NOT_DEFINED","vulnerabilityResponseEffort":"NOT_DEFINED","providerUrgency":"NOT_DEFINED","version":"4.0","baseSeverity":"MEDIUM","baseScore":6.4,"vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94: Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"AMZN","orgId":"ff89ba41-3aa1-4d27-914a-91399e9639e5","dateUpdated":"2026-07-30T18:14:32.806Z"},"impacts":[{"capecId":"CAPEC-242","descriptions":[{"lang":"en","value":"CAPEC-242: Code Injection"}]}],"cpeApplicability":[{"operator":"OR","nodes":[{"operator":"OR","negate":false,"cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:aws:amplify_codegen_ui:*:*:*:*:*:*:*:*","versionStartIncluding":"0","versionEndExcluding":"2.20.6"}]}]}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 1.0.4"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-07-30T19:13:26.893924Z","id":"CVE-2026-18245","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-07-30T19:15:12.776Z"}}]}}}