{"id":"CVE-2026-15304","state":"PUBLISHED","title":"Plugin Organizer <= 10.2.4 - Authenticated (Subscriber+) SQL Injection","description":"The Plugin Organizer plugin for WordPress is vulnerable to SQL Injection via the 'PO_plugin_path' parameter in versions up to, and including, 10.2.4. This is due to insufficient escaping on the user-supplied parameter in the perform_plugin_search() function, where esc_sql() output is passed as the replacement string to preg_replace(), which collapses backslash escapes and defeats the quoting protection; additionally, the AJAX handler lacks both nonce verification and capability checks. This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.","publishedAt":"2026-07-28T18:35:51.726Z","updatedAt":"2026-07-28T18:55:08.501Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["foomagoo Plugin Organizer"],"affected":[{"vendor":"foomagoo","product":"Plugin Organizer","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"10.2.4","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/c3ca06c0-6a7d-43ee-ac59-698e0f525e23?source=cve","https://plugins.trac.wordpress.org/browser/plugin-organizer/tags/10.2.4/lib/PO_Ajax.class.php#L985","https://plugins.trac.wordpress.org/browser/plugin-organizer/tags/10.2.4/lib/PO_Ajax.class.php#L969","https://plugins.trac.wordpress.org/browser/plugin-organizer/tags/10.2.4/lib/PluginOrganizer.class.php#L126","https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3603359%40plugin-organizer%2Ftags%2F10.2.5%2Flib%2FPO_Ajax.class.php&old=%20%20%203405892%40plugin-organizer%2Ftags%2F10.2.4%2Flib%2FPO_Ajax.class.php&sfp_email=&sfph_mail="],"weaknesses":["CWE-89"],"ingestedAt":"2026-10-29T20:11:00.674Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/15xxx/CVE-2026-15304.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-15304","state":"PUBLISHED","datePublished":"2026-07-28T18:35:51.726Z","dateUpdated":"2026-07-28T18:55:08.501Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-07-09T16:13:51.370Z"},"containers":{"cna":{"title":"Plugin Organizer <= 10.2.4 - Authenticated (Subscriber+) SQL Injection","descriptions":[{"lang":"en","value":"The Plugin Organizer plugin for WordPress is vulnerable to SQL Injection via the 'PO_plugin_path' parameter in versions up to, and including, 10.2.4. This is due to insufficient escaping on the user-supplied parameter in the perform_plugin_search() function, where esc_sql() output is passed as the replacement string to preg_replace(), which collapses backslash escapes and defeats the quoting protection; additionally, the AJAX handler lacks both nonce verification and capability checks. This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database."}],"affected":[{"vendor":"foomagoo","product":"Plugin Organizer","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"10.2.4","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/c3ca06c0-6a7d-43ee-ac59-698e0f525e23?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/plugin-organizer/tags/10.2.4/lib/PO_Ajax.class.php#L985"},{"url":"https://plugins.trac.wordpress.org/browser/plugin-organizer/tags/10.2.4/lib/PO_Ajax.class.php#L969"},{"url":"https://plugins.trac.wordpress.org/browser/plugin-organizer/tags/10.2.4/lib/PluginOrganizer.class.php#L126"},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3603359%40plugin-organizer%2Ftags%2F10.2.5%2Flib%2FPO_Ajax.class.php&old=%20%20%203405892%40plugin-organizer%2Ftags%2F10.2.4%2Flib%2FPO_Ajax.class.php&sfp_email=&sfph_mail="}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","baseScore":6.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-89","lang":"en","description":"CWE-89 Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-07-28T18:35:51.726Z"},"credits":[{"lang":"en","type":"finder","value":"zhuxuan wu"}],"timeline":[{"time":"2026-07-27T20:32:04.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-07-28T18:54:59.323325Z","id":"CVE-2026-15304","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-07-28T18:55:08.501Z"}}]}}}