{"id":"CVE-2026-14955","state":"PUBLISHED","title":"Checkout Field Editor for WooCommerce (Pro) <= 3.7.7 - Authenticated (Subscriber+) Path Traversal to Arbitrary File Read via 'thwcfe_legacy_file' Parameter","description":"The Checkout Field Editor for WooCommerce (Pro) plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 3.7.7 via the 'thwcfe_legacy_file' parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.","publishedAt":"2026-07-25T05:34:55.666Z","updatedAt":"2026-07-27T13:58:42.946Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["Themehigh Checkout Field Editor for WooCommerce (Pro)"],"affected":[{"vendor":"Themehigh","product":"Checkout Field Editor for WooCommerce (Pro)","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.7.7","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/a9576cee-2375-437e-9dc8-713209a96a73?source=cve","https://www.themehigh.com/product/woocommerce-checkout-field-editor-pro/"],"weaknesses":["CWE-22"],"ingestedAt":"2026-10-29T20:11:00.674Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/14xxx/CVE-2026-14955.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-14955","state":"PUBLISHED","datePublished":"2026-07-25T05:34:55.666Z","dateUpdated":"2026-07-27T13:58:42.946Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-07-07T13:32:03.687Z"},"containers":{"cna":{"title":"Checkout Field Editor for WooCommerce (Pro) <= 3.7.7 - Authenticated (Subscriber+) Path Traversal to Arbitrary File Read via 'thwcfe_legacy_file' Parameter","descriptions":[{"lang":"en","value":"The Checkout Field Editor for WooCommerce (Pro) plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 3.7.7 via the 'thwcfe_legacy_file' parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information."}],"affected":[{"vendor":"Themehigh","product":"Checkout Field Editor for WooCommerce (Pro)","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"3.7.7","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/a9576cee-2375-437e-9dc8-713209a96a73?source=cve"},{"url":"https://www.themehigh.com/product/woocommerce-checkout-field-editor-pro/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","baseScore":6.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-22","lang":"en","description":"CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-07-25T05:34:55.666Z"},"credits":[{"lang":"en","type":"finder","value":"0xd4rk5id3"}],"timeline":[{"time":"2026-07-24T17:26:59.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-07-27T13:58:24.414083Z","id":"CVE-2026-14955","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-07-27T13:58:42.946Z"}}]}}}