{"id":"CVE-2026-14529","state":"PUBLISHED","title":"IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by a server-side request forgery","description":"IBM WebSphere Application Server 9.0, and 8.5 and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 traditional is vulnerable to server-side request forgery (SSRF) when the SIP container feature (sipServlet-1.1) is enabled.","publishedAt":"2026-07-29T18:15:18.180Z","updatedAt":"2026-07-30T03:55:39.717Z","severity":{"score":9.4,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L","source":"ibm"},"assigner":"ibm","products":["IBM WebSphere Application Server","IBM WebSphere Application Server - Liberty"],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","versions":[{"version":"9.0","status":"affected"},{"version":"8.5","status":"affected"}]},{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.8","versionType":"semver"}]}],"references":["https://www.ibm.com/support/pages/node/7281721"],"weaknesses":["CWE-306"],"ingestedAt":"2026-10-29T20:11:00.674Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/14xxx/CVE-2026-14529.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-14529","state":"PUBLISHED","datePublished":"2026-07-29T18:15:18.180Z","dateUpdated":"2026-07-30T03:55:39.717Z","assignerShortName":"ibm","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateReserved":"2026-07-02T20:25:40.691Z"},"containers":{"cna":{"title":"IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by a server-side request forgery","descriptions":[{"lang":"en","value":"IBM WebSphere Application Server 9.0, and 8.5 and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.8 traditional is vulnerable to server-side request forgery (SSRF) when the SIP container feature (sipServlet-1.1) is enabled."}],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","versions":[{"version":"9.0","status":"affected"},{"version":"8.5","status":"affected"}]},{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.8","versionType":"semver"}]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7281721","tags":["vendor-advisory","patch"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"HIGH","availabilityImpact":"LOW","baseSeverity":"CRITICAL","baseScore":9.4,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-306","lang":"en","description":"CWE-306 Missing Authentication for Critical Function","type":"CWE"}]}],"providerMetadata":{"shortName":"ibm","orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateUpdated":"2026-07-29T18:15:18.180Z"},"solutions":[{"lang":"en","value":"IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH72053 or DT495928. To determine if a feature is enabled for WebSphere Application Server Liberty, refer to  How to determine if Liberty is using a specific feature https://www.ibm.com/support/pages/node/6553910 . \n\n\n\nFor IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.8 using the sipServlet-1.1 feature:\n\n\n\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves  PH72053 https://www.ibm.com/support/pages/node/7281718 \n--OR--\n· Apply Fix Pack 26.0.0.9 or later (targeted availability 3Q2026).\n\n\n\n\n\nFor IBM WebSphere Application Server traditional:\n\n\n\nFor V9.0.0.0 through 9.0.5.28:\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves  DT495928 https://www.ibm.com/support/pages/node/7281717 \n--OR--\n· Apply Fix Pack 9.0.5.29 or later (targeted availability 3Q2026).  \n\n\n\nFor V8.5.0.0 through 8.5.5.30:\n· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix that resolves  DT495928 https://www.ibm.com/support/pages/node/7281717 \n--OR--\n· Apply Fix Pack 8.5.5.31 or later (targeted availability 3Q2026).\n\n\n\n\n\n\n\nAdditional interim fixes may be available and linked off the interim fix download page.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH72053 or DT495928. To determine if a feature is enabled for WebSphere Application Server Liberty, refer to <a href=\"https://www.ibm.com/support/pages/node/6553910\" rel=\"nofollow\">How to determine if Liberty is using a specific feature</a>. </p><div><p><strong>For IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.8 using the sipServlet-1.1 feature:</strong></p><p>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7281718\" rel=\"nofollow\">PH72053</a><br/>--OR--<br/>· Apply Fix Pack 26.0.0.9 or later (targeted availability 3Q2026).</p></div><p><strong>For IBM WebSphere Application Server traditional:</strong></p><p><strong>For V9.0.0.0 through 9.0.5.28:</strong><br/>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7281717\" rel=\"nofollow\">DT495928</a><br/>--OR--<br/>· Apply Fix Pack 9.0.5.29 or later (targeted availability 3Q2026).  </p><p><strong>For V8.5.0.0 through 8.5.5.30:</strong><br/>· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7281717\" rel=\"nofollow\">DT495928</a><br/>--OR--<br/>· Apply Fix Pack 8.5.5.31 or later (targeted availability 3Q2026).</p><p></p><p>Additional interim fixes may be available and linked off the interim fix download page.</p>"}]}],"x_generator":{"engine":"ibm-cvegen"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-07-29T00:00:00+00:00","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3","id":"CVE-2026-14529"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-07-30T03:55:39.717Z"}}]}}}