{"id":"CVE-2026-1378","state":"PUBLISHED","title":"WP Posts Re-order <= 1.0 - Cross-Site Request Forgery to Settings Update","description":"The WP Posts Re-order plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0. This is due to missing nonce validation on the `cpt_plugin_options()` function. This makes it possible for unauthenticated attackers to update the plugin settings including capability, autosort, and adminsort settings, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2026-03-21T03:26:36.543Z","updatedAt":"2026-04-08T16:38:06.091Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["suifengtec WP Posts Re-order"],"affected":[{"vendor":"suifengtec","product":"WP Posts Re-order","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/1a79d08e-9429-4895-bc0c-cfaa8eb161d6?source=cve","https://plugins.trac.wordpress.org/browser/wp-posts-re-order/trunk/wp-posts-re-order.php#L572","https://plugins.trac.wordpress.org/browser/wp-posts-re-order/tags/1.0/wp-posts-re-order.php#L572"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:11:10.572Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/1xxx/CVE-2026-1378.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-1378","state":"PUBLISHED","datePublished":"2026-03-21T03:26:36.543Z","dateUpdated":"2026-04-08T16:38:06.091Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-01-23T18:29:35.917Z"},"containers":{"cna":{"title":"WP Posts Re-order <= 1.0 - Cross-Site Request Forgery to Settings Update","descriptions":[{"lang":"en","value":"The WP Posts Re-order plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0. This is due to missing nonce validation on the `cpt_plugin_options()` function. This makes it possible for unauthenticated attackers to update the plugin settings including capability, autosort, and adminsort settings, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"suifengtec","product":"WP Posts Re-order","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/1a79d08e-9429-4895-bc0c-cfaa8eb161d6?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wp-posts-re-order/trunk/wp-posts-re-order.php#L572"},{"url":"https://plugins.trac.wordpress.org/browser/wp-posts-re-order/tags/1.0/wp-posts-re-order.php#L572"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:38:06.091Z"},"credits":[{"lang":"en","type":"finder","value":"Muhammad Nur Ibnu Hubab"}],"timeline":[{"time":"2026-03-20T15:19:15.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-03-24T14:56:22.203489Z","id":"CVE-2026-1378","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-03-24T15:09:14.591Z"}}]}}}