{"id":"CVE-2026-1242","state":"PUBLISHED","title":"BlockSpare - Gutenberg Site Builder Blocks & Starter Sites <= 4.2.6 - Incorrect Authorization to Authenticated (Subscriber+) Arbitrary Post Creation","description":"The BlockSpare plugin for WordPress is vulnerable to authorization bypass due to incorrect logic in the permission callback in all versions up to, and including, 4.2.6 due to the use of an AND (&&) operator instead of an OR (||) operator. This makes it possible for authenticated attackers, with Subscriber-level access and above, to bypass authorization checks and create arbitrary posts.","publishedAt":"2026-09-19T07:43:14.563Z","updatedAt":"2026-09-19T14:01:24.156Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["blockspare BlockSpare – Gutenberg Blocks for News, Magazine, Blog & Business Websites"],"affected":[{"vendor":"blockspare","product":"BlockSpare – Gutenberg Blocks for News, Magazine, Blog & Business Websites","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.2.6","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/2e1bbaa2-5bb3-442e-b4a8-96db98500e7b?source=cve","https://plugins.trac.wordpress.org/browser/blockspare/tags/3.3.0/inc/layout/save-templates.php#L9"],"weaknesses":["CWE-863"],"ingestedAt":"2026-10-29T20:11:10.572Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/1xxx/CVE-2026-1242.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-1242","state":"PUBLISHED","datePublished":"2026-09-19T07:43:14.563Z","dateUpdated":"2026-09-19T14:01:24.156Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-01-20T18:43:48.857Z"},"containers":{"cna":{"title":"BlockSpare - Gutenberg Site Builder Blocks & Starter Sites <= 4.2.6 - Incorrect Authorization to Authenticated (Subscriber+) Arbitrary Post Creation","descriptions":[{"lang":"en","value":"The BlockSpare plugin for WordPress is vulnerable to authorization bypass due to incorrect logic in the permission callback in all versions up to, and including, 4.2.6 due to the use of an AND (&&) operator instead of an OR (||) operator. This makes it possible for authenticated attackers, with Subscriber-level access and above, to bypass authorization checks and create arbitrary posts."}],"affected":[{"vendor":"blockspare","product":"BlockSpare – Gutenberg Blocks for News, Magazine, Blog & Business Websites","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.2.6","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/2e1bbaa2-5bb3-442e-b4a8-96db98500e7b?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/blockspare/tags/3.3.0/inc/layout/save-templates.php#L9"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-863","lang":"en","description":"CWE-863 Incorrect Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-09-19T07:43:14.563Z"},"credits":[{"lang":"en","type":"finder","value":"Osvaldo Noe Gonzalez Del Rio (Os)"}],"timeline":[{"time":"2026-09-18T19:07:44.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2026-1242","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2026-09-19T13:24:02.142885Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-09-19T14:01:24.156Z"}}]}}}