{"id":"CVE-2026-118905","state":"PUBLISHED","title":"nvm_ls lets an untrusted version string inject sed commands, executing arbitrary commands with GNU sed","description":"Node Version Manager (nvm) is a POSIX-compliant shell function for managing multiple node.js versions. In versions 0.31.2 through 0.40.5, `nvm_ls` filters installed versions with a sed program that embeds the requested version pattern in a `\\#...#` address, escaping `.` (and, since 0.40.4, `#`) but not backslash. A version string containing `#` (or `\\#`) therefore closes the address early, and the rest of it is parsed as sed commands: with GNU sed, the `e` command runs a shell command as the user; with BSD sed, the `w` and `r` commands write and read files. This is reachable whenever an attacker-influenced version string is passed to `nvm use`, `nvm which`, `nvm ls`, `nvm version`, `nvm run`, or `nvm exec`, or to `nvm-exec` via `NODE_VERSION`, and at least one version is installed. nvm's own `.nvmrc` parser strips comments, so a bare `nvm use` is not affected; however, the bash `cdnvm` and zsh `load-nvmrc` auto-switch hooks documented in the README read `.nvmrc` as-is and pass it to `nvm ls` and `nvm version`, so a user with one of those hooks installed runs the attacker's command just by changing into a directory under a malicious `.nvmrc`; scripts that run `nvm use \"$(cat .nvmrc)\"` are affected the same way. Version 0.40.6 passes any version pattern containing `#` or a newline through the `.nvmrc` content parser first, so no `#` reaches the sed program.","publishedAt":"2026-10-29T05:22:35.156Z","updatedAt":"2026-10-29T05:22:35.156Z","severity":{"score":7.1,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","source":"harborist"},"assigner":"harborist","products":["nvm-sh nvm"],"affected":[{"vendor":"nvm-sh","product":"nvm","defaultStatus":"unaffected","versions":[{"version":"0.31.2","status":"affected","lessThan":"0.40.6","versionType":"semver"}],"repo":"https://github.com/nvm-sh/nvm"}],"references":["https://github.com/nvm-sh/nvm/security/advisories/GHSA-vgqf-vc3m-4wv3","https://github.com/nvm-sh/nvm/commit/82315e2b189528a006da6701eac30e8c364ffd22","https://github.com/nvm-sh/nvm/pull/3854","https://github.com/nvm-sh/nvm/releases/tag/v0.40.6"],"weaknesses":["CWE-78","CWE-94"],"ingestedAt":"2026-10-29T20:10:52.580Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/118xxx/CVE-2026-118905.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-118905","state":"PUBLISHED","datePublished":"2026-10-29T05:22:35.156Z","dateUpdated":"2026-10-29T05:22:35.156Z","assignerShortName":"harborist","assignerOrgId":"7ffcee3d-2c14-4c3e-b844-86c6a321a158","dateReserved":"2026-10-29T05:21:07.784Z"},"containers":{"cna":{"title":"nvm_ls lets an untrusted version string inject sed commands, executing arbitrary commands with GNU sed","descriptions":[{"lang":"en","value":"Node Version Manager (nvm) is a POSIX-compliant shell function for managing multiple node.js versions. In versions 0.31.2 through 0.40.5, `nvm_ls` filters installed versions with a sed program that embeds the requested version pattern in a `\\#...#` address, escaping `.` (and, since 0.40.4, `#`) but not backslash. A version string containing `#` (or `\\#`) therefore closes the address early, and the rest of it is parsed as sed commands: with GNU sed, the `e` command runs a shell command as the user; with BSD sed, the `w` and `r` commands write and read files. This is reachable whenever an attacker-influenced version string is passed to `nvm use`, `nvm which`, `nvm ls`, `nvm version`, `nvm run`, or `nvm exec`, or to `nvm-exec` via `NODE_VERSION`, and at least one version is installed. nvm's own `.nvmrc` parser strips comments, so a bare `nvm use` is not affected; however, the bash `cdnvm` and zsh `load-nvmrc` auto-switch hooks documented in the README read `.nvmrc` as-is and pass it to `nvm ls` and `nvm version`, so a user with one of those hooks installed runs the attacker's command just by changing into a directory under a malicious `.nvmrc`; scripts that run `nvm use \"$(cat .nvmrc)\"` are affected the same way. Version 0.40.6 passes any version pattern containing `#` or a newline through the `.nvmrc` content parser first, so no `#` reaches the sed program."}],"affected":[{"vendor":"nvm-sh","product":"nvm","defaultStatus":"unaffected","versions":[{"version":"0.31.2","status":"affected","lessThan":"0.40.6","versionType":"semver"}],"repo":"https://github.com/nvm-sh/nvm"}],"references":[{"url":"https://github.com/nvm-sh/nvm/security/advisories/GHSA-vgqf-vc3m-4wv3","name":"GHSA-vgqf-vc3m-4wv3","tags":["vendor-advisory"]},{"url":"https://github.com/nvm-sh/nvm/commit/82315e2b189528a006da6701eac30e8c364ffd22","name":"Fix commit 82315e2b","tags":["patch"]},{"url":"https://github.com/nvm-sh/nvm/pull/3854","name":"nvm-sh/nvm#3854","tags":["patch"]},{"url":"https://github.com/nvm-sh/nvm/releases/tag/v0.40.6","name":"v0.40.6","tags":["release-notes"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV4_0":{"attackVector":"LOCAL","attackComplexity":"LOW","attackRequirements":"PRESENT","privilegesRequired":"NONE","userInteraction":"ACTIVE","vulnConfidentialityImpact":"HIGH","subConfidentialityImpact":"NONE","vulnIntegrityImpact":"HIGH","subIntegrityImpact":"NONE","vulnAvailabilityImpact":"HIGH","subAvailabilityImpact":"NONE","exploitMaturity":"NOT_DEFINED","Safety":"NOT_DEFINED","Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","valueDensity":"NOT_DEFINED","vulnerabilityResponseEffort":"NOT_DEFINED","providerUrgency":"NOT_DEFINED","version":"4.0","baseSeverity":"HIGH","baseScore":7.1,"vectorString":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"}},{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"LOCAL","attackComplexity":"HIGH","privilegesRequired":"NONE","userInteraction":"REQUIRED","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"HIGH","availabilityImpact":"HIGH","baseSeverity":"HIGH","baseScore":7,"vectorString":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-78","lang":"en","description":"CWE-78 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"harborist","orgId":"7ffcee3d-2c14-4c3e-b844-86c6a321a158","dateUpdated":"2026-10-29T05:22:35.156Z"},"workarounds":[{"lang":"en","value":"Until upgrading, do not pass untrusted version strings to nvm, and use nvm's own `.nvmrc` handling (a bare `nvm use`) instead of reading `.nvmrc` yourself, including in shell auto-switch hooks.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>Until upgrading, do not pass untrusted version strings to nvm, and use nvm's own `.nvmrc` handling (a bare `nvm use`) instead of reading `.nvmrc` yourself, including in shell auto-switch hooks.</p>"}]}],"solutions":[{"lang":"en","value":"Upgrade to nvm 0.40.6 or later.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>Upgrade to nvm 0.40.6 or later.</p>"}]}],"credits":[{"lang":"en","value":"vnth4nhnt of CyStack (https://github.com/vnth4nhnt)","type":"finder"},{"lang":"en","value":"sjh9714 (https://github.com/sjh9714)","type":"remediation developer"}],"source":{"advisory":"GHSA-vgqf-vc3m-4wv3","discovery":"EXTERNAL"}}}}}