{"id":"CVE-2026-114598","state":"PUBLISHED","title":"Access of resource using incompatible type ('type confusion') in EPICS Base","description":"In EPICS Base release 7.0.10 and prior, an insufficient validation of element or length values in a network message can cause the application to read beyond the bounds of an allocated buffer. This may lead to denial of service and could expose adjacent memory contents.","publishedAt":"2026-10-27T16:53:28.775Z","updatedAt":"2026-10-27T16:53:28.775Z","severity":{"score":8.7,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","source":"icscert"},"assigner":"icscert","products":["The EPICS Community EPICS Base"],"affected":[{"vendor":"The EPICS Community","product":"EPICS Base","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.0.10","versionType":"custom"}]}],"references":["https://www.cisa.gov/news-events/ics-advisories/icsa-26-300-01"],"weaknesses":["CWE-843"],"ingestedAt":"2026-10-29T20:10:43.281Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/114xxx/CVE-2026-114598.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-114598","state":"PUBLISHED","datePublished":"2026-10-27T16:53:28.775Z","dateUpdated":"2026-10-27T16:53:28.775Z","assignerShortName":"icscert","assignerOrgId":"7d14cffa-0d7d-4270-9dc0-52cabd5a23a6","dateReserved":"2026-10-21T20:17:35.041Z"},"containers":{"cna":{"title":"Access of resource using incompatible type ('type confusion') in EPICS Base","descriptions":[{"lang":"en","value":"In EPICS Base release 7.0.10 and prior, an insufficient validation of element or length values in a network message can cause the application to read beyond the bounds of an allocated buffer. This may lead to denial of service and could expose adjacent memory contents."}],"affected":[{"vendor":"The EPICS Community","product":"EPICS Base","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.0.10","versionType":"custom"}]}],"references":[{"url":"https://www.cisa.gov/news-events/ics-advisories/icsa-26-300-01","tags":["government-resource"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"NONE","integrityImpact":"NONE","availabilityImpact":"HIGH","baseSeverity":"HIGH","baseScore":7.5,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"}},{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"NONE","subConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","subIntegrityImpact":"NONE","vulnAvailabilityImpact":"HIGH","subAvailabilityImpact":"NONE","exploitMaturity":"NOT_DEFINED","Safety":"NOT_DEFINED","Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","valueDensity":"NOT_DEFINED","vulnerabilityResponseEffort":"NOT_DEFINED","providerUrgency":"NOT_DEFINED","version":"4.0","baseSeverity":"HIGH","baseScore":8.7,"vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N"}},{"other":{"type":"ssvc","content":{"options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CNA","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-843","lang":"en","description":"CWE-843 Access of resource using incompatible type ('type confusion')","type":"CWE"}]}],"providerMetadata":{"shortName":"icscert","orgId":"7d14cffa-0d7d-4270-9dc0-52cabd5a23a6","dateUpdated":"2026-10-27T16:53:28.775Z"},"solutions":[{"lang":"en","value":"The EPICS Community has made available updates to the epics-base GitHub repositories. Affected users should update to the 7.0.11 release. For more information, users should contact the EPICS Controls team https://epics-controls.org/support/.\n\n\n\nhttps://github.com/epics-base/epics-base/pull/934\nhttps://github.com/epics-base/epics-base/pull/937\nhttps://github.com/epics-base/pvDataCPP/pull/109","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>The EPICS Community has made available updates to the epics-base GitHub repositories. Affected users should update to the 7.0.11 release. For more information, users should contact the EPICS Controls team https://epics-controls.org/support/.</p><p>https://github.com/epics-base/epics-base/pull/934<br>https://github.com/epics-base/epics-base/pull/937<br>https://github.com/epics-base/pvDataCPP/pull/109</p>"}]}],"credits":[{"lang":"en","value":"Shubham Raj of Cipher / Causal Security reported these vulnerabilities to CISA.","type":"finder"}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 1.0.5"}}}}}