{"id":"CVE-2026-10842","state":"PUBLISHED","title":"IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by a security bypass vulnerability","description":"IBM WebSphere Application Server 8.5, and 9.0 and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.7 Traditional and Liberty could allow a remote attacker to bypass security constraints.","publishedAt":"2026-07-30T15:57:16.828Z","updatedAt":"2026-07-30T17:37:19.123Z","severity":{"score":7.5,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","source":"ibm"},"assigner":"ibm","products":["IBM WebSphere Application Server","IBM WebSphere Application Server - Liberty"],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","versions":[{"version":"8.5","status":"affected"},{"version":"9.0","status":"affected"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:8.5:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:8.5.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:9.0.0:*:*:*:*:*:*:*"]},{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.7","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server_liberty:17.0.0.3:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server_liberty:26.0.0.7:*:*:*:*:*:*:*"]}],"references":["https://www.ibm.com/support/pages/node/7280131"],"weaknesses":["CWE-289"],"ingestedAt":"2026-10-29T20:10:33.477Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/10xxx/CVE-2026-10842.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-10842","state":"PUBLISHED","datePublished":"2026-07-30T15:57:16.828Z","dateUpdated":"2026-07-30T17:37:19.123Z","assignerShortName":"ibm","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateReserved":"2026-06-04T11:48:12.087Z"},"containers":{"cna":{"title":"IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by a security bypass vulnerability","descriptions":[{"lang":"en","value":"IBM WebSphere Application Server 8.5, and 9.0 and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.7 Traditional and Liberty could allow a remote attacker to bypass security constraints."}],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","versions":[{"version":"8.5","status":"affected"},{"version":"9.0","status":"affected"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:8.5:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:8.5.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:9.0.0:*:*:*:*:*:*:*"]},{"vendor":"IBM","product":"WebSphere Application Server - Liberty","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"26.0.0.7","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server_liberty:17.0.0.3:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server_liberty:26.0.0.7:*:*:*:*:*:*:*"]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7280131","tags":["vendor-advisory","patch"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"NONE","availabilityImpact":"NONE","baseSeverity":"HIGH","baseScore":7.5,"vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-289","lang":"en","description":"CWE-289 Authentication Bypass by Alternate Name","type":"CWE"}]}],"providerMetadata":{"shortName":"ibm","orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateUpdated":"2026-07-30T15:57:16.828Z"},"solutions":[{"lang":"en","value":"IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH71893 and PH71916 . To determine if a feature is enabled for WebSphere Application Server Liberty, refer to  How to determine if Liberty is using a specific feature https://www.ibm.com/support/pages/node/6553910 . \n\n\n\nFor IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.7 using appSecurity-1.0, appSecurity-2.0 , appSecurity-3.0 and appSecurity-4.0 features:\n\n\n\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves  PH71916 https://www.ibm.com/support/pages/node/7280086 \n--OR--\n· Apply Fix Pack 26.0.0.8 or later (targeted availability 3Q2026).\n\n\n\n\n\nFor IBM WebSphere Application Server traditional:\n\n\n\nFor V9.0.0.0 through 9.0.5.28:\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves  PH71893 https://www.ibm.com/support/pages/node/7280079 \n--OR--\n· Apply Fix Pack 9.0.5.29 or later (targeted availability 3Q2026).  \n\n\n\nFor V8.5.0.0 through 8.5.5.30:\n· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix that resolves  PH71893 https://www.ibm.com/support/pages/node/7280079 \n--OR--\n· Apply Fix Pack 8.5.5.31 or later (targeted availability 3Q2026).\n\n\n\n\n\n\n\nAdditional interim fixes may be available and linked off the interim fix download page.","supportingMedia":[{"type":"text/html","base64":false,"value":"<p>IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH71893 and PH71916 . To determine if a feature is enabled for WebSphere Application Server Liberty, refer to <a href=\"https://www.ibm.com/support/pages/node/6553910\" rel=\"nofollow\">How to determine if Liberty is using a specific feature</a>. </p><div><p><strong>For IBM WebSphere Application Server Liberty 17.0.0.3 - 26.0.0.7 using appSecurity-1.0, appSecurity-2.0 , appSecurity-3.0 and appSecurity-4.0 features:</strong></p><p>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7280086\" rel=\"nofollow\">PH71916</a><br/>--OR--<br/>· Apply Fix Pack 26.0.0.8 or later (targeted availability 3Q2026).</p></div><p><strong>For IBM WebSphere Application Server traditional:</strong></p><p><strong>For V9.0.0.0 through 9.0.5.28:</strong><br/>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7280079\" rel=\"nofollow\">PH71893</a><br/>--OR--<br/>· Apply Fix Pack 9.0.5.29 or later (targeted availability 3Q2026).  </p><p><strong>For V8.5.0.0 through 8.5.5.30:</strong><br/>· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix that resolves <a href=\"https://www.ibm.com/support/pages/node/7280079\" rel=\"nofollow\">PH71893</a><br/>--OR--<br/>· Apply Fix Pack 8.5.5.31 or later (targeted availability 3Q2026).</p><p></p><p>Additional interim fixes may be available and linked off the interim fix download page.</p>"}]}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-07-30T17:35:27.364790Z","id":"CVE-2026-10842","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-07-30T17:37:19.123Z"}}]}}}