{"id":"CVE-2026-107812","state":"PUBLISHED","title":"Nginx UI: Self-upgrade runs an unsigned binary verified only by a same-origin digest → RCE via a compromised mirror or MITM","description":"Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, the self-upgrade mechanism validates a downloaded binary only with a same-origin digest obtained from the same upgrade mirror. A compromised mirror or network attacker able to alter both responses can supply a malicious executable and matching digest. An operator-triggered upgrade is required, and the application installs and runs the attacker-controlled code in the Nginx UI process context on the next upgrade. This issue is fixed in version 2.5.0.","publishedAt":"2026-10-09T15:41:04.107Z","updatedAt":"2026-10-09T19:07:43.373Z","severity":{"score":7.5,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["0xJacky nginx-ui"],"affected":[{"vendor":"0xJacky","product":"nginx-ui","versions":[{"version":">= 2.0.0, < 2.5.0","status":"affected"}]}],"references":["https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2","https://github.com/0xJacky/nginx-ui/commit/580585516dd87a8b176bcdac258db70c3b64b7ec","https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0"],"weaknesses":["CWE-494"],"ingestedAt":"2026-10-29T20:10:23.711Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/107xxx/CVE-2026-107812.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-107812","state":"PUBLISHED","datePublished":"2026-10-09T15:41:04.107Z","dateUpdated":"2026-10-09T19:07:43.373Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2026-10-08T21:23:59.822Z"},"containers":{"cna":{"title":"Nginx UI: Self-upgrade runs an unsigned binary verified only by a same-origin digest → RCE via a compromised mirror or MITM","descriptions":[{"lang":"en","value":"Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, the self-upgrade mechanism validates a downloaded binary only with a same-origin digest obtained from the same upgrade mirror. A compromised mirror or network attacker able to alter both responses can supply a malicious executable and matching digest. An operator-triggered upgrade is required, and the application installs and runs the attacker-controlled code in the Nginx UI process context on the next upgrade. This issue is fixed in version 2.5.0."}],"affected":[{"vendor":"0xJacky","product":"nginx-ui","versions":[{"version":">= 2.0.0, < 2.5.0","status":"affected"}]}],"references":[{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2","name":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/0xJacky/nginx-ui/commit/580585516dd87a8b176bcdac258db70c3b64b7ec","name":"https://github.com/0xJacky/nginx-ui/commit/580585516dd87a8b176bcdac258db70c3b64b7ec","tags":["x_refsource_MISC"]},{"url":"https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0","name":"https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":7.5,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-494","lang":"en","description":"CWE-494: Download of Code Without Integrity Check","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2026-10-09T15:41:04.107Z"},"source":{"advisory":"GHSA-662p-52hx-cmh2","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","references":[{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-662p-52hx-cmh2","tags":["exploit"]}],"metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-10-09T19:07:36.816766Z","id":"CVE-2026-107812","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-10-09T19:07:43.373Z"}}]}}}