{"id":"CVE-2026-103358","state":"PUBLISHED","title":"WordPress Email Template Customizer for WooCommerce plugin <= 1.3.4 - Content Injection vulnerability","description":"Improper Control of Generation of Code ('Code Injection') vulnerability in VillaTheme Email Template Customizer for WooCommerce email-template-customizer-for-woo allows Code Injection.This issue affects Email Template Customizer for WooCommerce: from n/a through 1.3.4.","publishedAt":"2026-10-14T11:00:11.345Z","updatedAt":"2026-10-15T16:43:48.459Z","severity":{"score":7.5,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","source":"Patchstack"},"assigner":"Patchstack","products":["VillaTheme Email Template Customizer for WooCommerce"],"affected":[{"vendor":"VillaTheme","product":"Email Template Customizer for WooCommerce","packageName":"email-template-customizer-for-woo","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.3.4","versionType":"custom","changes":[{"at":"1.3.5","status":"unaffected"}]}],"collectionURL":"https://wordpress.org/plugins"}],"references":["https://patchstack.com/database/wordpress/plugin/email-template-customizer-for-woo/vulnerability/wordpress-email-template-customizer-for-woocommerce-plugin-1-3-4-content-injection-vulnerability?_s_id=cve"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:10:23.711Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/103xxx/CVE-2026-103358.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-103358","state":"PUBLISHED","datePublished":"2026-10-14T11:00:11.345Z","dateUpdated":"2026-10-15T16:43:48.459Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2026-09-30T12:43:33.094Z"},"containers":{"cna":{"title":"WordPress Email Template Customizer for WooCommerce plugin <= 1.3.4 - Content Injection vulnerability","descriptions":[{"lang":"en","value":"Improper Control of Generation of Code ('Code Injection') vulnerability in VillaTheme Email Template Customizer for WooCommerce email-template-customizer-for-woo allows Code Injection.This issue affects Email Template Customizer for WooCommerce: from n/a through 1.3.4."}],"affected":[{"vendor":"VillaTheme","product":"Email Template Customizer for WooCommerce","packageName":"email-template-customizer-for-woo","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.3.4","versionType":"custom","changes":[{"at":"1.3.5","status":"unaffected"}]}],"collectionURL":"https://wordpress.org/plugins"}],"references":[{"url":"https://patchstack.com/database/wordpress/plugin/email-template-customizer-for-woo/vulnerability/wordpress-email-template-customizer-for-woocommerce-plugin-1-3-4-content-injection-vulnerability?_s_id=cve","tags":["vdb-entry"]}],"metrics":[{"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}],"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","baseScore":7.5,"baseSeverity":"HIGH","attackVector":"NETWORK","attackComplexity":"LOW","privilegesRequired":"NONE","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"NONE","availabilityImpact":"NONE"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","description":"Improper Control of Generation of Code ('Code Injection')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-10-14T11:00:11.345Z"},"datePublic":"2026-10-12T10:42:04.000Z","credits":[{"lang":"en","value":"cazy | Patchstack Bug Bounty Program","type":"finder"}],"impacts":[{"capecId":"CAPEC-242","descriptions":[{"lang":"en","value":"Code Injection"}]}],"solutions":[{"lang":"en","value":"Update the WordPress Email Template Customizer for WooCommerce plugin to the latest available version (at least 1.3.5).","supportingMedia":[{"type":"text/html","base64":false,"value":"Update the WordPress Email Template Customizer for WooCommerce plugin to the latest available version (at least 1.3.5)."}]}],"tags":["x_open-source"]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2026-103358","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"version":"2.0.3","timestamp":"2026-10-15T10:51:23.574008Z"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-10-15T16:43:48.459Z"}}]}}}