{"id":"CVE-2026-102905","state":"PUBLISHED","title":"Ad Inserter <= 2.8.19 - Unauthenticated Arbitrary Shortcode Execution via 's' Search Parameter","description":"The The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.8.19 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Exploitation requires an administrator to have configured an ad block containing a dynamic tag such as {title}, {tag}, {category}, or {smart-tag} with display enabled on search pages, which is a normal and documented plugin configuration.","publishedAt":"2026-10-30T17:15:29.355Z","updatedAt":"2026-10-30T17:24:48.214Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["spacetime Ad Inserter – Ad Manager & AdSense Ads"],"affected":[{"vendor":"spacetime","product":"Ad Inserter – Ad Manager & AdSense Ads","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.8.19","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/a36f813c-97c5-466d-92e0-7341c12b5a46?source=cve","https://plugins.trac.wordpress.org/browser/ad-inserter/tags/2.8.19/class.php#L3297","https://plugins.trac.wordpress.org/browser/ad-inserter/tags/2.8.19/ad-inserter.php#L12974","https://plugins.trac.wordpress.org/browser/ad-inserter/tags/2.8.19/ad-inserter.php#L13142","https://plugins.trac.wordpress.org/changeset/3770281/ad-inserter/trunk/ad-inserter.php"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-30T17:28:06.624Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/102xxx/CVE-2026-102905.json","commit":"3341b8c15da9d44519feb86e18f02f360209d08a","baselineCommit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-102905","state":"PUBLISHED","datePublished":"2026-10-30T17:15:29.355Z","dateUpdated":"2026-10-30T17:24:48.214Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2026-09-29T17:36:54.940Z"},"containers":{"cna":{"title":"Ad Inserter <= 2.8.19 - Unauthenticated Arbitrary Shortcode Execution via 's' Search Parameter","descriptions":[{"lang":"en","value":"The The Ad Inserter – Ad Manager & AdSense Ads plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.8.19 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Exploitation requires an administrator to have configured an ad block containing a dynamic tag such as {title}, {tag}, {category}, or {smart-tag} with display enabled on search pages, which is a normal and documented plugin configuration."}],"affected":[{"vendor":"spacetime","product":"Ad Inserter – Ad Manager & AdSense Ads","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.8.19","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/a36f813c-97c5-466d-92e0-7341c12b5a46?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/ad-inserter/tags/2.8.19/class.php#L3297"},{"url":"https://plugins.trac.wordpress.org/browser/ad-inserter/tags/2.8.19/ad-inserter.php#L12974"},{"url":"https://plugins.trac.wordpress.org/browser/ad-inserter/tags/2.8.19/ad-inserter.php#L13142"},{"url":"https://plugins.trac.wordpress.org/changeset/3770281/ad-inserter/trunk/ad-inserter.php"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","baseScore":6.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94 Improper Control of Generation of Code","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-10-30T17:15:29.355Z"},"credits":[{"lang":"en","type":"finder","value":"Kuba"}],"timeline":[{"time":"2026-09-29T17:52:08.000Z","lang":"en","value":"Vendor Notified"},{"time":"2026-10-30T16:13:18.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-10-30T17:24:39.208478Z","id":"CVE-2026-102905","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-10-30T17:24:48.214Z"}}]}}}