{"id":"CVE-2026-100310","state":"PUBLISHED","title":"GNU libextractor before 1.16 Privilege Escalation via LIBEXTRACTOR_PREFIX","description":"GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program.","publishedAt":"2026-09-25T19:38:28.517Z","updatedAt":"2026-09-30T00:05:50.934Z","severity":{"score":7.3,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","source":"VulnCheck"},"assigner":"VulnCheck","products":["GNU libextractor"],"affected":[{"vendor":"GNU","product":"libextractor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"1.16","versionType":"custom"}]}],"references":["https://github.com/Haitam-lazaar/libextractor-privesc","https://git.gnunet.org/gnunet/libextractor/commit/6edfa653c048800e24a17f7e8cc2bb42659b8d01.html","https://ftp.gnu.org/gnu/libextractor/","https://www.gnu.org/software/libextractor/","https://www.vulncheck.com/advisories/gnu-libextractor-before-1.16-privilege-escalation-via-libextractor-prefix","http://www.openwall.com/lists/oss-security/2026/09/25/25"],"weaknesses":["CWE-426"],"ingestedAt":"2026-10-29T20:10:13.529Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/100xxx/CVE-2026-100310.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-100310","state":"PUBLISHED","datePublished":"2026-09-25T19:38:28.517Z","dateUpdated":"2026-09-30T00:05:50.934Z","assignerShortName":"VulnCheck","assignerOrgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateReserved":"2026-09-25T19:01:58.216Z"},"containers":{"cna":{"title":"GNU libextractor before 1.16 Privilege Escalation via LIBEXTRACTOR_PREFIX","descriptions":[{"lang":"en","value":"GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks. A local attacker can exploit this by setting LIBEXTRACTOR_PREFIX to a directory containing a malicious plugin that executes arbitrary code with elevated privileges when loaded by a setuid or setgid program."}],"affected":[{"vendor":"GNU","product":"libextractor","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"1.16","versionType":"custom"}]}],"references":[{"url":"https://github.com/Haitam-lazaar/libextractor-privesc","tags":["exploit","third-party-advisory"]},{"url":"https://git.gnunet.org/gnunet/libextractor/commit/6edfa653c048800e24a17f7e8cc2bb42659b8d01.html","tags":["patch"]},{"url":"https://ftp.gnu.org/gnu/libextractor/","tags":["release-notes"]},{"url":"https://www.gnu.org/software/libextractor/","tags":["product"]},{"url":"https://www.vulncheck.com/advisories/gnu-libextractor-before-1.16-privilege-escalation-via-libextractor-prefix","name":"VulnCheck Advisory: GNU libextractor before 1.16 Privilege Escalation via LIBEXTRACTOR_PREFIX","tags":["third-party-advisory"]}],"metrics":[{"format":"CVSS","cvssV4_0":{"version":"4.0","vectorString":"CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","attackVector":"LOCAL","attackComplexity":"LOW","attackRequirements":"PRESENT","privilegesRequired":"LOW","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnAvailabilityImpact":"HIGH","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":7.3,"baseSeverity":"HIGH"}},{"format":"CVSS","cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","attackVector":"LOCAL","attackComplexity":"HIGH","privilegesRequired":"LOW","userInteraction":"NONE","scope":"UNCHANGED","confidentialityImpact":"HIGH","integrityImpact":"HIGH","availabilityImpact":"HIGH","baseScore":7,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-426","lang":"en","description":"Untrusted Search Path","type":"CWE"}]}],"providerMetadata":{"shortName":"VulnCheck","orgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateUpdated":"2026-09-25T19:38:28.517Z"},"datePublic":"2026-06-30T00:00:00.000Z","cpeApplicability":[{"nodes":[{"operator":"OR","negate":false,"cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:gnu:libextractor:*:*:*:*:*:*:*:*","versionEndExcluding":"1.16"}]}]}],"credits":[{"lang":"en","value":"Haitam Lazaar","type":"finder"}],"x_generator":{"engine":"vulncheck-endgame"}},"adp":[{"title":"CVE Program Container","references":[{"url":"http://www.openwall.com/lists/oss-security/2026/09/25/25"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2026-09-26T00:18:30.975Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-09-30T00:05:41.549904Z","id":"CVE-2026-100310","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-09-30T00:05:50.934Z"}}]}}}