{"id":"CVE-2025-9636","state":"PUBLISHED","title":"Cross-Origin Opener Policy Vulnerability in pgAdmin 4","description":"pgAdmin <= 9.7 is affected by a  Cross-Origin Opener Policy (COOP) vulnerability. This vulnerability allows an attacker to manipulate the OAuth flow, potentially leading to unauthorised account access, account takeover, data breaches, and privilege escalation.","publishedAt":"2025-09-04T16:43:27.710Z","updatedAt":"2026-02-26T17:49:38.292Z","severity":{"score":7.9,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L","source":"PostgreSQL"},"assigner":"PostgreSQL","products":["pgadmin.org pgAdmin 4"],"affected":[{"vendor":"pgadmin.org","product":"pgAdmin 4","defaultStatus":"affected","versions":[{"version":"0","status":"affected","lessThan":"9.8","versionType":"custom"}],"modules":["OAuth 2 Authentication"],"repo":"https://github.com/pgadmin-org/pgadmin4"}],"references":["https://github.com/pgadmin-org/pgadmin4/issues/9114"],"weaknesses":["CWE-346"],"ingestedAt":"2026-10-29T20:10:13.529Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/9xxx/CVE-2025-9636.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-9636","state":"PUBLISHED","datePublished":"2025-09-04T16:43:27.710Z","dateUpdated":"2026-02-26T17:49:38.292Z","assignerShortName":"PostgreSQL","assignerOrgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","dateReserved":"2025-08-28T20:28:18.654Z"},"containers":{"cna":{"title":"Cross-Origin Opener Policy Vulnerability in pgAdmin 4","descriptions":[{"lang":"en","value":"pgAdmin <= 9.7 is affected by a  Cross-Origin Opener Policy (COOP) vulnerability. This vulnerability allows an attacker to manipulate the OAuth flow, potentially leading to unauthorised account access, account takeover, data breaches, and privilege escalation."}],"affected":[{"vendor":"pgadmin.org","product":"pgAdmin 4","defaultStatus":"affected","versions":[{"version":"0","status":"affected","lessThan":"9.8","versionType":"custom"}],"modules":["OAuth 2 Authentication"],"repo":"https://github.com/pgadmin-org/pgadmin4"}],"references":[{"url":"https://github.com/pgadmin-org/pgadmin4/issues/9114","tags":["issue-tracking"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":7.9,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"providerMetadata":{"shortName":"PostgreSQL","orgId":"f86ef6dc-4d3a-42ad-8f28-e6d5547a5007","dateUpdated":"2025-09-04T16:43:27.710Z"},"datePublic":"2025-08-27T18:30:00.000Z","source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.1.0-dev"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"id":"CVE-2025-9636","role":"CISA Coordinator","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"version":"2.0.3","timestamp":"2025-09-05T03:55:49.987660Z"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-346","lang":"en","type":"CWE","description":"CWE-346 Origin Validation Error"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-02-26T17:49:38.292Z"}}]}}}