{"id":"CVE-2025-9634","state":"PUBLISHED","title":"Plugin updates blocker <= 0.2 - Cross-Site Request Forgery","description":"The Plugin updates blocker plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 0.2. This is due to missing or incorrect nonce validation on the pub_save action handler. This makes it possible for unauthenticated attackers to disable or enable plugin updates via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2025-09-11T07:24:55.037Z","updatedAt":"2026-04-08T16:59:00.776Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["jegerwan Plugin updates blocker"],"affected":[{"vendor":"jegerwan","product":"Plugin updates blocker","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/6b66a0bc-9125-45ee-9583-bc503634a0ce?source=cve","https://plugins.trac.wordpress.org/browser/plugin-update-blocker/tags/0.2/dpu-menu.php#L3"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:10:13.529Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/9xxx/CVE-2025-9634.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-9634","state":"PUBLISHED","datePublished":"2025-09-11T07:24:55.037Z","dateUpdated":"2026-04-08T16:59:00.776Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-08-28T20:05:57.726Z"},"containers":{"cna":{"title":"Plugin updates blocker <= 0.2 - Cross-Site Request Forgery","descriptions":[{"lang":"en","value":"The Plugin updates blocker plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 0.2. This is due to missing or incorrect nonce validation on the pub_save action handler. This makes it possible for unauthenticated attackers to disable or enable plugin updates via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"jegerwan","product":"Plugin updates blocker","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/6b66a0bc-9125-45ee-9583-bc503634a0ce?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/plugin-update-blocker/tags/0.2/dpu-menu.php#L3"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:59:00.776Z"},"credits":[{"lang":"en","type":"finder","value":"Nabil Irawan"}],"timeline":[{"time":"2025-09-10T18:44:07.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-11T14:03:38.334798Z","id":"CVE-2025-9634","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-09-11T14:39:31.029Z"}}]}}}