{"id":"CVE-2025-9353","state":"PUBLISHED","title":"Themify Builder <= 7.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9.","publishedAt":"2025-09-24T12:27:28.647Z","updatedAt":"2026-04-08T16:52:22.072Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["themifyme Themify Builder"],"affected":[{"vendor":"themifyme","product":"Themify Builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.6.9","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/508e97a0-9757-426c-bf0f-cdce6b489ce7?source=cve","https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-icon.php#L95","https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L73","https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L96","https://plugins.trac.wordpress.org/browser/themify-builder/trunk/js/editor/build/modules.min.js","https://plugins.trac.wordpress.org/changeset/3366817/","https://plugins.trac.wordpress.org/changeset/3355757/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:10:13.529Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/9xxx/CVE-2025-9353.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-9353","state":"PUBLISHED","datePublished":"2025-09-24T12:27:28.647Z","dateUpdated":"2026-04-08T16:52:22.072Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-08-22T14:58:02.773Z"},"containers":{"cna":{"title":"Themify Builder <= 7.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9."}],"affected":[{"vendor":"themifyme","product":"Themify Builder","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.6.9","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/508e97a0-9757-426c-bf0f-cdce6b489ce7?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-icon.php#L95"},{"url":"https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L73"},{"url":"https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L96"},{"url":"https://plugins.trac.wordpress.org/browser/themify-builder/trunk/js/editor/build/modules.min.js"},{"url":"https://plugins.trac.wordpress.org/changeset/3366817/"},{"url":"https://plugins.trac.wordpress.org/changeset/3355757/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:52:22.072Z"},"credits":[{"lang":"en","type":"finder","value":"D.Sim"}],"timeline":[{"time":"2025-08-27T03:40:16.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-09-23T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-24T13:00:05.384680Z","id":"CVE-2025-9353","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-09-24T13:00:24.349Z"}}]}}}