{"id":"CVE-2025-9080","state":"PUBLISHED","title":"Generic Elements <= 1.2.8 - Authenticated (Contributor+) Stored Cross-Site Scripting","description":"The Generic Elements plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple widget fields in version 1.2.8 and earlier. This is due to insufficient input sanitization and output escaping on user-supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-10-03T11:17:14.730Z","updatedAt":"2026-04-08T17:02:18.437Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["bdevs Generic Elements"],"affected":[{"vendor":"bdevs","product":"Generic Elements","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.2.8","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/7a341a7e-9ed2-436f-846a-59a5d51916fe?source=cve","https://plugins.trac.wordpress.org/browser/generic-elements-for-elementor/tags/1.2.4/widgets/FunFactor.php#L692","https://plugins.trac.wordpress.org/browser/generic-elements-for-elementor/tags/1.2.4/widgets/Slider.php#L1025","https://plugins.trac.wordpress.org/browser/generic-elements-for-elementor/tags/1.2.8/widgets/CallToAction.php#L1110"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:10:13.529Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/9xxx/CVE-2025-9080.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-9080","state":"PUBLISHED","datePublished":"2025-10-03T11:17:14.730Z","dateUpdated":"2026-04-08T17:02:18.437Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-08-15T15:44:59.195Z"},"containers":{"cna":{"title":"Generic Elements <= 1.2.8 - Authenticated (Contributor+) Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Generic Elements plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple widget fields in version 1.2.8 and earlier. This is due to insufficient input sanitization and output escaping on user-supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"bdevs","product":"Generic Elements","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.2.8","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/7a341a7e-9ed2-436f-846a-59a5d51916fe?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/generic-elements-for-elementor/tags/1.2.4/widgets/FunFactor.php#L692"},{"url":"https://plugins.trac.wordpress.org/browser/generic-elements-for-elementor/tags/1.2.4/widgets/Slider.php#L1025"},{"url":"https://plugins.trac.wordpress.org/browser/generic-elements-for-elementor/tags/1.2.8/widgets/CallToAction.php#L1110"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:02:18.437Z"},"credits":[{"lang":"en","type":"finder","value":"Abu Hurayra"},{"lang":"en","type":"finder","value":"D.Sim"}],"timeline":[{"time":"2025-10-02T22:11:08.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-10-03T14:56:53.124011Z","id":"CVE-2025-9080","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-10-03T14:56:59.307Z"}}]}}}