{"id":"CVE-2025-8315","state":"PUBLISHED","title":"WP Easy Contact <= 4.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via noaccess_msg Parameter","description":"The WP Easy Contact plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘noaccess_msg’ parameter in all versions up to, and including, 4.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-08-05T06:39:48.070Z","updatedAt":"2026-04-08T16:41:43.296Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["emarket-design Simple Contact Form Plugin for WordPress – WP Easy Contact"],"affected":[{"vendor":"emarket-design","product":"Simple Contact Form Plugin for WordPress – WP Easy Contact","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.0.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/229c88ea-c091-43b6-ac4d-31bccdd13a07?source=cve","https://plugins.svn.wordpress.org/wp-easy-contact/tags/4.0.1/includes/emd-form-builder-lite/emd-form-frontend.php","https://wordpress.org/plugins/wp-easy-contact/#developers","https://plugins.trac.wordpress.org/changeset/3337661"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:10:04.440Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/8xxx/CVE-2025-8315.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-8315","state":"PUBLISHED","datePublished":"2025-08-05T06:39:48.070Z","dateUpdated":"2026-04-08T16:41:43.296Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-07-29T20:35:49.918Z"},"containers":{"cna":{"title":"WP Easy Contact <= 4.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via noaccess_msg Parameter","descriptions":[{"lang":"en","value":"The WP Easy Contact plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘noaccess_msg’ parameter in all versions up to, and including, 4.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"emarket-design","product":"Simple Contact Form Plugin for WordPress – WP Easy Contact","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.0.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/229c88ea-c091-43b6-ac4d-31bccdd13a07?source=cve"},{"url":"https://plugins.svn.wordpress.org/wp-easy-contact/tags/4.0.1/includes/emd-form-builder-lite/emd-form-frontend.php"},{"url":"https://wordpress.org/plugins/wp-easy-contact/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3337661"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:41:43.296Z"},"credits":[{"lang":"en","type":"finder","value":"Muhammad Yudha - DJ"}],"timeline":[{"time":"2025-07-30T08:23:06.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-08-04T17:36:03.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-08-05T13:23:11.868848Z","id":"CVE-2025-8315","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-08-05T13:23:20.107Z"}}]}}}