{"id":"CVE-2025-8147","state":"PUBLISHED","title":"LWSCache <= 2.8.5 - Missing Authorization to Authenticated (Subscriber+) Limited Plugin Activation via lwscache_activatePlugin Function","description":"The LWSCache plugin for WordPress is vulnerable to unauthorized modification of data due to improper authorization on the lwscache_activatePlugin() function in all versions up to, and including, 2.8.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to activate arbitrary whitelisted LWS plugins.","publishedAt":"2025-08-29T04:25:28.386Z","updatedAt":"2026-04-08T16:32:35.860Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["aurelienlws LWSCache"],"affected":[{"vendor":"aurelienlws","product":"LWSCache","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.8.5","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/01a6a5bf-636b-416c-86fa-43f639624e80?source=cve","https://plugins.trac.wordpress.org/browser/lwscache/tags/2.8.5/lwscache.php#L401","https://wordpress.org/plugins/lwscache/#developers","https://plugins.trac.wordpress.org/changeset/3352047/"],"weaknesses":["CWE-285"],"ingestedAt":"2026-10-29T20:10:04.440Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/8xxx/CVE-2025-8147.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-8147","state":"PUBLISHED","datePublished":"2025-08-29T04:25:28.386Z","dateUpdated":"2026-04-08T16:32:35.860Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-07-24T21:11:54.996Z"},"containers":{"cna":{"title":"LWSCache <= 2.8.5 - Missing Authorization to Authenticated (Subscriber+) Limited Plugin Activation via lwscache_activatePlugin Function","descriptions":[{"lang":"en","value":"The LWSCache plugin for WordPress is vulnerable to unauthorized modification of data due to improper authorization on the lwscache_activatePlugin() function in all versions up to, and including, 2.8.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to activate arbitrary whitelisted LWS plugins."}],"affected":[{"vendor":"aurelienlws","product":"LWSCache","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.8.5","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/01a6a5bf-636b-416c-86fa-43f639624e80?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/lwscache/tags/2.8.5/lwscache.php#L401"},{"url":"https://wordpress.org/plugins/lwscache/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3352047/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-285","lang":"en","description":"CWE-285 Improper Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:32:35.860Z"},"credits":[{"lang":"en","type":"finder","value":"wesley"}],"timeline":[{"time":"2025-08-28T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-08-29T12:03:48.434562Z","id":"CVE-2025-8147","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-08-29T12:03:54.361Z"}}]}}}