{"id":"CVE-2025-8064","state":"PUBLISHED","title":"Bible SuperSearch <= 6.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via selector_height Parameter","description":"The Bible SuperSearch plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘selector_height’ parameter in all versions up to, and including, 6.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-08-21T09:26:02.544Z","updatedAt":"2026-04-08T16:38:10.364Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["aicwebtech Bible SuperSearch"],"affected":[{"vendor":"aicwebtech","product":"Bible SuperSearch","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"6.0.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/1ada39db-b316-4270-ac9c-3770b473d6a8?source=cve","https://plugins.trac.wordpress.org/browser/biblesupersearch/trunk/wp/class.shortcodes.php#L270","https://wordpress.org/plugins/biblesupersearch/#developers","https://plugins.trac.wordpress.org/changeset/3345278/","https://github.com/aicwebtech/Bible-SuperSearch-WordPress-Plugin/commit/535e1a48a6d6135020209adfd9881a0c1878b741#diff-e60090bad955f035bce7cebd3a9a1e9555f5692fa74c17a24a31cfc1557d04d6"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:10:04.440Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/8xxx/CVE-2025-8064.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-8064","state":"PUBLISHED","datePublished":"2025-08-21T09:26:02.544Z","dateUpdated":"2026-04-08T16:38:10.364Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-07-22T21:21:00.367Z"},"containers":{"cna":{"title":"Bible SuperSearch <= 6.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via selector_height Parameter","descriptions":[{"lang":"en","value":"The Bible SuperSearch plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘selector_height’ parameter in all versions up to, and including, 6.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"aicwebtech","product":"Bible SuperSearch","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"6.0.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/1ada39db-b316-4270-ac9c-3770b473d6a8?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/biblesupersearch/trunk/wp/class.shortcodes.php#L270"},{"url":"https://wordpress.org/plugins/biblesupersearch/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3345278/"},{"url":"https://github.com/aicwebtech/Bible-SuperSearch-WordPress-Plugin/commit/535e1a48a6d6135020209adfd9881a0c1878b741#diff-e60090bad955f035bce7cebd3a9a1e9555f5692fa74c17a24a31cfc1557d04d6"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:38:10.364Z"},"credits":[{"lang":"en","type":"finder","value":"Peter Thaleikis"}],"timeline":[{"time":"2025-07-25T14:42:32.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-08-20T20:41:27.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-08-21T13:50:22.741517Z","id":"CVE-2025-8064","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-08-21T13:50:33.314Z"}}]}}}