{"id":"CVE-2025-7668","state":"PUBLISHED","title":"Linux Promotional Plugin <= 1.4 - Cross-Site Request Forgery to Stored Cross-Site Scripting","description":"The Linux Promotional Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4. This is due to missing or incorrect nonce validation on the 'inux-promotional-plugin.php' page. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2025-08-16T03:38:50.955Z","updatedAt":"2026-04-08T17:05:38.878Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["timothyja Linux Promotional Plugin"],"affected":[{"vendor":"timothyja","product":"Linux Promotional Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.4","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/8a3e3d91-5ce5-4db1-856e-c1d12471f9ed?source=cve","https://plugins.trac.wordpress.org/browser/linux-promotional-plugin/trunk/linux-promotional-plugin.php","https://wordpress.org/plugins/linux-promotional-plugin/"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:10:04.440Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/7xxx/CVE-2025-7668.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-7668","state":"PUBLISHED","datePublished":"2025-08-16T03:38:50.955Z","dateUpdated":"2026-04-08T17:05:38.878Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-07-14T21:47:08.450Z"},"containers":{"cna":{"title":"Linux Promotional Plugin <= 1.4 - Cross-Site Request Forgery to Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Linux Promotional Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4. This is due to missing or incorrect nonce validation on the 'inux-promotional-plugin.php' page. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"timothyja","product":"Linux Promotional Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.4","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/8a3e3d91-5ce5-4db1-856e-c1d12471f9ed?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/linux-promotional-plugin/trunk/linux-promotional-plugin.php"},{"url":"https://wordpress.org/plugins/linux-promotional-plugin/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","baseScore":6.1,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:05:38.878Z"},"credits":[{"lang":"en","type":"finder","value":"JohSka"}],"timeline":[{"time":"2025-08-15T14:48:12.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-08-18T13:40:55.354329Z","id":"CVE-2025-7668","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-08-18T13:41:00.740Z"}}]}}}