{"id":"CVE-2025-6990","state":"PUBLISHED","title":"Kallyas <= 4.24.0 - Authenticated (Contributor+) Remote Code Execution","description":"The kallyas theme for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.24.0 via the  `TH_PhpCode` pagebuilder widget. This is due to the theme not restricting access to the code editor widget for non-administrators. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server.","publishedAt":"2025-11-01T07:30:03.218Z","updatedAt":"2026-04-08T17:00:41.322Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["hogash KALLYAS - Creative eCommerce Multi-Purpose WordPress Theme"],"affected":[{"vendor":"hogash","product":"KALLYAS - Creative eCommerce Multi-Purpose WordPress Theme","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.24.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/721d29e4-397d-4965-bd64-33bced8e5de4?source=cve","https://my.hogash.com/changelog_category/kallyas-wordpress-theme/"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:10:04.440Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/6xxx/CVE-2025-6990.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-6990","state":"PUBLISHED","datePublished":"2025-11-01T07:30:03.218Z","dateUpdated":"2026-04-08T17:00:41.322Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-07-01T21:10:09.036Z"},"containers":{"cna":{"title":"Kallyas <= 4.24.0 - Authenticated (Contributor+) Remote Code Execution","descriptions":[{"lang":"en","value":"The kallyas theme for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.24.0 via the  `TH_PhpCode` pagebuilder widget. This is due to the theme not restricting access to the code editor widget for non-administrators. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server."}],"affected":[{"vendor":"hogash","product":"KALLYAS - Creative eCommerce Multi-Purpose WordPress Theme","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.24.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/721d29e4-397d-4965-bd64-33bced8e5de4?source=cve"},{"url":"https://my.hogash.com/changelog_category/kallyas-wordpress-theme/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:00:41.322Z"},"credits":[{"lang":"en","type":"finder","value":"Matthew Rollings"}],"timeline":[{"time":"2026-02-12T20:10:06.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-10-31T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-11-03T13:22:08.024137Z","id":"CVE-2025-6990","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-11-03T13:30:17.631Z"}}]}}}