{"id":"CVE-2025-6941","state":"PUBLISHED","title":"LatePoint <= 5.1.94 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","description":"The LatePoint – Calendar Booking Plugin for Appointments and Events plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' parameter of the 'latepoint_resources' shortcode in all versions up to, and including, 5.1.94 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-09-30T04:27:07.055Z","updatedAt":"2026-04-08T17:19:37.055Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["latepoint LatePoint – Calendar Booking Plugin for Appointments and Events"],"affected":[{"vendor":"latepoint","product":"LatePoint – Calendar Booking Plugin for Appointments and Events","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.1.94","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/c05575ef-3140-4340-9b4b-1803a8045ce0?source=cve","https://wordpress.org/plugins/latepoint/#developers","https://plugins.trac.wordpress.org/browser/latepoint/tags/5.1.93/lib/helpers/shortcodes_helper.php","https://plugins.trac.wordpress.org/changeset/3366851"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:10:04.440Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/6xxx/CVE-2025-6941.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-6941","state":"PUBLISHED","datePublished":"2025-09-30T04:27:07.055Z","dateUpdated":"2026-04-08T17:19:37.055Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-06-30T21:18:16.014Z"},"containers":{"cna":{"title":"LatePoint <= 5.1.94 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","descriptions":[{"lang":"en","value":"The LatePoint – Calendar Booking Plugin for Appointments and Events plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' parameter of the 'latepoint_resources' shortcode in all versions up to, and including, 5.1.94 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"latepoint","product":"LatePoint – Calendar Booking Plugin for Appointments and Events","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.1.94","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/c05575ef-3140-4340-9b4b-1803a8045ce0?source=cve"},{"url":"https://wordpress.org/plugins/latepoint/#developers"},{"url":"https://plugins.trac.wordpress.org/browser/latepoint/tags/5.1.93/lib/helpers/shortcodes_helper.php"},{"url":"https://plugins.trac.wordpress.org/changeset/3366851"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:19:37.055Z"},"credits":[{"lang":"en","type":"finder","value":"Muhammad Yudha - DJ"}],"timeline":[{"time":"2025-07-08T16:23:03.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-09-29T16:24:40.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-30T15:39:38.627496Z","id":"CVE-2025-6941","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-09-30T15:39:46.996Z"}}]}}}