{"id":"CVE-2025-68115","state":"PUBLISHED","title":"Parse Server vulnerable to Cross-Site Scripting (XSS) via Unescaped Mustache Template Variables","description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 8.6.1 and 9.1.0-alpha.3, a Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages. The patch, available in versions 8.6.1 and 9.1.0-alpha.3, escapes user controlled values that are inserted into the HTML pages. No known workarounds are available.","publishedAt":"2025-12-16T00:56:23.452Z","updatedAt":"2025-12-16T21:20:24.376Z","severity":{"score":5.3,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["parse-community parse-server"],"affected":[{"vendor":"parse-community","product":"parse-server","versions":[{"version":"< 8.6.1","status":"affected"},{"version":">= 9.0.0, < 9.1.0-alpha.3","status":"affected"}]}],"references":["https://github.com/parse-community/parse-server/security/advisories/GHSA-jhgf-2h8h-ggxv","https://github.com/parse-community/parse-server/pull/9985","https://github.com/parse-community/parse-server/pull/9986"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:09:56.034Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/68xxx/CVE-2025-68115.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-68115","state":"PUBLISHED","datePublished":"2025-12-16T00:56:23.452Z","dateUpdated":"2025-12-16T21:20:24.376Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-12-15T16:16:22.744Z"},"containers":{"cna":{"title":"Parse Server vulnerable to Cross-Site Scripting (XSS) via Unescaped Mustache Template Variables","descriptions":[{"lang":"en","value":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 8.6.1 and 9.1.0-alpha.3, a Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages. The patch, available in versions 8.6.1 and 9.1.0-alpha.3, escapes user controlled values that are inserted into the HTML pages. No known workarounds are available."}],"affected":[{"vendor":"parse-community","product":"parse-server","versions":[{"version":"< 8.6.1","status":"affected"},{"version":">= 9.0.0, < 9.1.0-alpha.3","status":"affected"}]}],"references":[{"url":"https://github.com/parse-community/parse-server/security/advisories/GHSA-jhgf-2h8h-ggxv","name":"https://github.com/parse-community/parse-server/security/advisories/GHSA-jhgf-2h8h-ggxv","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/parse-community/parse-server/pull/9985","name":"https://github.com/parse-community/parse-server/pull/9985","tags":["x_refsource_MISC"]},{"url":"https://github.com/parse-community/parse-server/pull/9986","name":"https://github.com/parse-community/parse-server/pull/9986","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"PASSIVE","vulnConfidentialityImpact":"LOW","vulnIntegrityImpact":"LOW","vulnAvailabilityImpact":"NONE","subConfidentialityImpact":"LOW","subIntegrityImpact":"LOW","subAvailabilityImpact":"NONE","baseScore":5.3,"baseSeverity":"MEDIUM","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-12-16T00:56:23.452Z"},"source":{"advisory":"GHSA-jhgf-2h8h-ggxv","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-16T21:15:05.512040Z","id":"CVE-2025-68115","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-12-16T21:20:24.376Z"}}]}}}