{"id":"CVE-2025-67723","state":"PUBLISHED","title":"Discourse vulnerable to stored Cross-site Scripting via Katex in discourse-math plugin","description":"Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX.","publishedAt":"2026-01-28T18:21:35.379Z","updatedAt":"2026-01-28T19:28:24.714Z","severity":{"score":4.6,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L","source":"GitHub_M"},"assigner":"GitHub_M","products":["discourse discourse"],"affected":[{"vendor":"discourse","product":"discourse","versions":[{"version":"< 3.5.4","status":"affected"},{"version":">= 2025.11.0-latest, < 2025.11.2","status":"affected"},{"version":">= 2025.12.0-latest, < 2025.12.1","status":"affected"},{"version":">= 2026.1.0-latest, < 2026.1.0","status":"affected"}]}],"references":["https://github.com/discourse/discourse/security/advisories/GHSA-955h-m28g-5379"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:09:56.034Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/67xxx/CVE-2025-67723.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-67723","state":"PUBLISHED","datePublished":"2026-01-28T18:21:35.379Z","dateUpdated":"2026-01-28T19:28:24.714Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-12-10T19:25:20.819Z"},"containers":{"cna":{"title":"Discourse vulnerable to stored Cross-site Scripting via Katex in discourse-math plugin","descriptions":[{"lang":"en","value":"Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX."}],"affected":[{"vendor":"discourse","product":"discourse","versions":[{"version":"< 3.5.4","status":"affected"},{"version":">= 2025.11.0-latest, < 2025.11.2","status":"affected"},{"version":">= 2025.12.0-latest, < 2025.12.1","status":"affected"},{"version":">= 2026.1.0-latest, < 2026.1.0","status":"affected"}]}],"references":[{"url":"https://github.com/discourse/discourse/security/advisories/GHSA-955h-m28g-5379","name":"https://github.com/discourse/discourse/security/advisories/GHSA-955h-m28g-5379","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":4.6,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2026-01-28T19:28:24.714Z"},"source":{"advisory":"GHSA-955h-m28g-5379","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-01-28T19:05:28.048224Z","id":"CVE-2025-67723","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-01-28T19:05:36.444Z"}}]}}}