{"id":"CVE-2025-66040","state":"PUBLISHED","title":"Spotipy has a XSS vulnerability in OAuth callback server","description":"Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.","publishedAt":"2025-11-26T23:14:44.795Z","updatedAt":"2025-11-28T15:25:40.139Z","severity":{"score":3.6,"label":"Low","version":"3.1","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["spotipy-dev spotipy"],"affected":[{"vendor":"spotipy-dev","product":"spotipy","versions":[{"version":"< 2.25.2","status":"affected"}]}],"references":["https://github.com/spotipy-dev/spotipy/security/advisories/GHSA-r77h-rpp9-w2xm","https://github.com/spotipy-dev/spotipy/commit/880b92d7243dcf2b83bf31dc365a858d8b5e6767"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:09:56.034Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/66xxx/CVE-2025-66040.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-66040","state":"PUBLISHED","datePublished":"2025-11-26T23:14:44.795Z","dateUpdated":"2025-11-28T15:25:40.139Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-11-21T01:08:02.615Z"},"containers":{"cna":{"title":"Spotipy has a XSS vulnerability in OAuth callback server","descriptions":[{"lang":"en","value":"Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2."}],"affected":[{"vendor":"spotipy-dev","product":"spotipy","versions":[{"version":"< 2.25.2","status":"affected"}]}],"references":[{"url":"https://github.com/spotipy-dev/spotipy/security/advisories/GHSA-r77h-rpp9-w2xm","name":"https://github.com/spotipy-dev/spotipy/security/advisories/GHSA-r77h-rpp9-w2xm","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/spotipy-dev/spotipy/commit/880b92d7243dcf2b83bf31dc365a858d8b5e6767","name":"https://github.com/spotipy-dev/spotipy/commit/880b92d7243dcf2b83bf31dc365a858d8b5e6767","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"LOCAL","availabilityImpact":"NONE","baseScore":3.6,"baseSeverity":"LOW","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-11-26T23:14:44.795Z"},"source":{"advisory":"GHSA-r77h-rpp9-w2xm","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-11-28T15:25:12.176179Z","id":"CVE-2025-66040","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-11-28T15:25:40.139Z"}}]}}}