{"id":"CVE-2025-65950","state":"PUBLISHED","title":"WBCE CMS is Vulnerable to Time-Based Blind SQL Injection through groups[] Parameter","description":"WBCE CMS is a content management system. In versions 1.6.4 and below, the user management module allows a low-privileged authenticated user with permissions to modify users to execute arbitrary SQL queries. This can be escalated to a full database compromise, data exfiltration, effectively bypassing all security controls. The vulnerability exists in the admin/users/save.php script, which handles updates to user profiles. The script improperly processes the groups[] parameter sent from the user edit form. This issue is fixed in version 1.6.5.","publishedAt":"2025-12-10T20:39:27.452Z","updatedAt":"2025-12-10T21:24:43.064Z","severity":{"score":9.4,"label":"Critical","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["WBCE WBCE_CMS"],"affected":[{"vendor":"WBCE","product":"WBCE_CMS","versions":[{"version":"< 1.6.5","status":"affected"}]}],"references":["https://github.com/WBCE/WBCE_CMS/security/advisories/GHSA-934v-xhx9-j2f3","https://github.com/WBCE/WBCE_CMS/commit/96046178f4c80cf16f7c224054dec7fdadddda7e","https://github.com/WBCE/WBCE_CMS/releases/tag/1.6.5"],"weaknesses":["CWE-89"],"ingestedAt":"2026-10-29T20:09:56.034Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/65xxx/CVE-2025-65950.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-65950","state":"PUBLISHED","datePublished":"2025-12-10T20:39:27.452Z","dateUpdated":"2025-12-10T21:24:43.064Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-11-18T16:14:56.692Z"},"containers":{"cna":{"title":"WBCE CMS is Vulnerable to Time-Based Blind SQL Injection through groups[] Parameter","descriptions":[{"lang":"en","value":"WBCE CMS is a content management system. In versions 1.6.4 and below, the user management module allows a low-privileged authenticated user with permissions to modify users to execute arbitrary SQL queries. This can be escalated to a full database compromise, data exfiltration, effectively bypassing all security controls. The vulnerability exists in the admin/users/save.php script, which handles updates to user profiles. The script improperly processes the groups[] parameter sent from the user edit form. This issue is fixed in version 1.6.5."}],"affected":[{"vendor":"WBCE","product":"WBCE_CMS","versions":[{"version":"< 1.6.5","status":"affected"}]}],"references":[{"url":"https://github.com/WBCE/WBCE_CMS/security/advisories/GHSA-934v-xhx9-j2f3","name":"https://github.com/WBCE/WBCE_CMS/security/advisories/GHSA-934v-xhx9-j2f3","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/WBCE/WBCE_CMS/commit/96046178f4c80cf16f7c224054dec7fdadddda7e","name":"https://github.com/WBCE/WBCE_CMS/commit/96046178f4c80cf16f7c224054dec7fdadddda7e","tags":["x_refsource_MISC"]},{"url":"https://github.com/WBCE/WBCE_CMS/releases/tag/1.6.5","name":"https://github.com/WBCE/WBCE_CMS/releases/tag/1.6.5","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"LOW","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnAvailabilityImpact":"HIGH","subConfidentialityImpact":"HIGH","subIntegrityImpact":"HIGH","subAvailabilityImpact":"HIGH","baseScore":9.4,"baseSeverity":"CRITICAL","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-89","lang":"en","description":"CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-12-10T20:39:27.452Z"},"source":{"advisory":"GHSA-934v-xhx9-j2f3","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-12-10T21:24:28.376311Z","id":"CVE-2025-65950","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-12-10T21:24:43.064Z"}}]}}}