{"id":"CVE-2025-64751","state":"PUBLISHED","title":"OpenFGA Improper Policy Enforcement","description":"OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.","publishedAt":"2025-11-21T01:24:32.509Z","updatedAt":"2025-11-24T18:11:03.949Z","severity":{"score":5.8,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["openfga openfga"],"affected":[{"vendor":"openfga","product":"openfga","versions":[{"version":">= 1.4.0, < 1.11.1","status":"affected"}]}],"references":["https://github.com/openfga/openfga/security/advisories/GHSA-2c64-vmv2-hgfc","https://github.com/openfga/openfga/releases/tag/v1.11.1"],"weaknesses":["CWE-285"],"ingestedAt":"2026-10-29T20:09:48.677Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/64xxx/CVE-2025-64751.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-64751","state":"PUBLISHED","datePublished":"2025-11-21T01:24:32.509Z","dateUpdated":"2025-11-24T18:11:03.949Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-11-10T22:29:34.873Z"},"containers":{"cna":{"title":"OpenFGA Improper Policy Enforcement","descriptions":[{"lang":"en","value":"OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1."}],"affected":[{"vendor":"openfga","product":"openfga","versions":[{"version":">= 1.4.0, < 1.11.1","status":"affected"}]}],"references":[{"url":"https://github.com/openfga/openfga/security/advisories/GHSA-2c64-vmv2-hgfc","name":"https://github.com/openfga/openfga/security/advisories/GHSA-2c64-vmv2-hgfc","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/openfga/openfga/releases/tag/v1.11.1","name":"https://github.com/openfga/openfga/releases/tag/v1.11.1","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"PRESENT","privilegesRequired":"LOW","userInteraction":"NONE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","vulnAvailabilityImpact":"NONE","subConfidentialityImpact":"HIGH","subIntegrityImpact":"HIGH","subAvailabilityImpact":"HIGH","baseScore":5.8,"baseSeverity":"MEDIUM","vectorString":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-285","lang":"en","description":"CWE-285: Improper Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-11-21T01:24:32.509Z"},"source":{"advisory":"GHSA-2c64-vmv2-hgfc","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-11-24T17:06:17.599165Z","id":"CVE-2025-64751","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-11-24T18:11:03.949Z"}}]}}}