{"id":"CVE-2025-6257","state":"PUBLISHED","title":"Euro FxRef Currency Converter <= 2.0.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via currency Shortcode","description":"The Euro FxRef Currency Converter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's currency shortcode in all versions up to, and including, 2.0.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-06-20T08:22:08.666Z","updatedAt":"2026-04-08T17:30:22.678Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["joostdekeijzer Euro FxRef Currency Converter (by DKZR)"],"affected":[{"vendor":"joostdekeijzer","product":"Euro FxRef Currency Converter (by DKZR)","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.0.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/e7637e96-3afe-46af-b99d-70abe9ca3e20?source=cve","https://wordpress.org/plugins/euro-fxref-currency-converter/#developers","https://github.com/joostdekeijzer/wp_eurofxref/commit/131108428f0d88dab1070048350bdd54f10c36a0","https://plugins.trac.wordpress.org/changeset/3314562"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:10:04.440Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/6xxx/CVE-2025-6257.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-6257","state":"PUBLISHED","datePublished":"2025-06-20T08:22:08.666Z","dateUpdated":"2026-04-08T17:30:22.678Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-06-18T21:52:34.226Z"},"containers":{"cna":{"title":"Euro FxRef Currency Converter <= 2.0.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via currency Shortcode","descriptions":[{"lang":"en","value":"The Euro FxRef Currency Converter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's currency shortcode in all versions up to, and including, 2.0.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"joostdekeijzer","product":"Euro FxRef Currency Converter (by DKZR)","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.0.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/e7637e96-3afe-46af-b99d-70abe9ca3e20?source=cve"},{"url":"https://wordpress.org/plugins/euro-fxref-currency-converter/#developers"},{"url":"https://github.com/joostdekeijzer/wp_eurofxref/commit/131108428f0d88dab1070048350bdd54f10c36a0"},{"url":"https://plugins.trac.wordpress.org/changeset/3314562"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:30:22.678Z"},"credits":[{"lang":"en","type":"finder","value":"Gilang Asra Bilhadi"}],"timeline":[{"time":"2025-06-19T07:23:56.000Z","lang":"en","value":"Vendor Notified"},{"time":"2025-06-19T19:52:17.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-06-20T12:38:09.629032Z","id":"CVE-2025-6257","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-06-20T13:10:41.216Z"}}]}}}