{"id":"CVE-2025-6040","state":"PUBLISHED","title":"Easy Flashcards <= 0.1 - Cross-Site Request Forgery to Stored Cross-Site Scripting","description":"The Easy Flashcards plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 0.1. This is due to missing or incorrect nonce validation on the 'ef_settings_submenu' page. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2025-06-14T08:23:23.104Z","updatedAt":"2026-04-08T16:41:08.875Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["sagesony Easy Flashcards"],"affected":[{"vendor":"sagesony","product":"Easy Flashcards","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/1ff97ee8-9732-4d26-b5e8-b744730e9c5a?source=cve","https://wordpress.org/plugins/easy-flashcards/#developers"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:10:04.440Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/6xxx/CVE-2025-6040.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-6040","state":"PUBLISHED","datePublished":"2025-06-14T08:23:23.104Z","dateUpdated":"2026-04-08T16:41:08.875Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-06-12T20:21:15.391Z"},"containers":{"cna":{"title":"Easy Flashcards <= 0.1 - Cross-Site Request Forgery to Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Easy Flashcards plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 0.1. This is due to missing or incorrect nonce validation on the 'ef_settings_submenu' page. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"sagesony","product":"Easy Flashcards","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"0.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/1ff97ee8-9732-4d26-b5e8-b744730e9c5a?source=cve"},{"url":"https://wordpress.org/plugins/easy-flashcards/#developers"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","baseScore":6.1,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:41:08.875Z"},"credits":[{"lang":"en","type":"finder","value":"JohSka"}],"timeline":[{"time":"2025-06-13T19:43:09.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-06-16T16:46:04.266465Z","id":"CVE-2025-6040","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-06-17T18:39:39.651Z"}}]}}}