{"id":"CVE-2025-59944","state":"PUBLISHED","title":"Cursor IDE: Sensitive File Overwrite Bypass is Possible","description":"Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.","publishedAt":"2025-10-03T20:15:30.678Z","updatedAt":"2025-10-03T20:43:03.394Z","severity":{"score":8.1,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["cursor cursor"],"affected":[{"vendor":"cursor","product":"cursor","versions":[{"version":"< 1.7","status":"affected"}]}],"references":["https://github.com/cursor/cursor/security/advisories/GHSA-xcwh-rrwj-gxc7"],"weaknesses":["CWE-178"],"ingestedAt":"2026-10-29T20:09:39.787Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/59xxx/CVE-2025-59944.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-59944","state":"PUBLISHED","datePublished":"2025-10-03T20:15:30.678Z","dateUpdated":"2025-10-03T20:43:03.394Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-09-23T14:33:49.505Z"},"containers":{"cna":{"title":"Cursor IDE: Sensitive File Overwrite Bypass is Possible","descriptions":[{"lang":"en","value":"Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7."}],"affected":[{"vendor":"cursor","product":"cursor","versions":[{"version":"< 1.7","status":"affected"}]}],"references":[{"url":"https://github.com/cursor/cursor/security/advisories/GHSA-xcwh-rrwj-gxc7","name":"https://github.com/cursor/cursor/security/advisories/GHSA-xcwh-rrwj-gxc7","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":8.1,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-178","lang":"en","description":"CWE-178: Improper Handling of Case Sensitivity","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-10-03T20:15:30.678Z"},"source":{"advisory":"GHSA-xcwh-rrwj-gxc7","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-10-03T20:42:37.081089Z","id":"CVE-2025-59944","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-10-03T20:43:03.394Z"}}]}}}