{"id":"CVE-2025-59933","state":"PUBLISHED","title":"libvips is vulnerable to Buffer Over-Read in poppler-based pdfload","description":"libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.","publishedAt":"2025-09-29T22:04:09.404Z","updatedAt":"2025-12-24T14:49:49.725Z","severity":{"score":5.1,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L","source":"GitHub_M"},"assigner":"GitHub_M","products":["libvips libvips"],"affected":[{"vendor":"libvips","product":"libvips","versions":[{"version":"< 8.17.2","status":"affected"}]}],"references":["https://github.com/libvips/libvips/security/advisories/GHSA-q8px-4w5q-c2r4","https://github.com/libvips/libvips/commit/a58bfae9223a5466cc81ba9fe6dfb08233cf17d1","https://github.com/libvips/libvips/releases/tag/v8.17.2","https://www.vicarius.io/vsociety/posts/cve-2025-59933-detect-libvips-vulnerability","https://www.vicarius.io/vsociety/posts/cve-2025-59933-mitigate-libvips-vulnerability"],"weaknesses":["CWE-126"],"ingestedAt":"2026-10-29T20:09:39.787Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/59xxx/CVE-2025-59933.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-59933","state":"PUBLISHED","datePublished":"2025-09-29T22:04:09.404Z","dateUpdated":"2025-12-24T14:49:49.725Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-09-23T14:33:49.504Z"},"containers":{"cna":{"title":"libvips is vulnerable to Buffer Over-Read in poppler-based pdfload","descriptions":[{"lang":"en","value":"libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler."}],"affected":[{"vendor":"libvips","product":"libvips","versions":[{"version":"< 8.17.2","status":"affected"}]}],"references":[{"url":"https://github.com/libvips/libvips/security/advisories/GHSA-q8px-4w5q-c2r4","name":"https://github.com/libvips/libvips/security/advisories/GHSA-q8px-4w5q-c2r4","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/libvips/libvips/commit/a58bfae9223a5466cc81ba9fe6dfb08233cf17d1","name":"https://github.com/libvips/libvips/commit/a58bfae9223a5466cc81ba9fe6dfb08233cf17d1","tags":["x_refsource_MISC"]},{"url":"https://github.com/libvips/libvips/releases/tag/v8.17.2","name":"https://github.com/libvips/libvips/releases/tag/v8.17.2","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"LOCAL","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"LOW","vulnIntegrityImpact":"LOW","vulnAvailabilityImpact":"LOW","subConfidentialityImpact":"LOW","subIntegrityImpact":"LOW","subAvailabilityImpact":"LOW","baseScore":5.1,"baseSeverity":"MEDIUM","vectorString":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-126","lang":"en","description":"CWE-126: Buffer Over-read","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-09-29T22:04:09.404Z"},"source":{"advisory":"GHSA-q8px-4w5q-c2r4","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-30T13:32:22.889441Z","id":"CVE-2025-59933","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-09-30T13:41:59.765Z"}},{"title":"CVE Program Container","references":[{"url":"https://www.vicarius.io/vsociety/posts/cve-2025-59933-detect-libvips-vulnerability"},{"url":"https://www.vicarius.io/vsociety/posts/cve-2025-59933-mitigate-libvips-vulnerability"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-12-24T14:49:49.725Z"},"x_generator":{"engine":"ADPogram 0.0.1"}}]}}}