{"id":"CVE-2025-5930","state":"PUBLISHED","title":"WP2HTML <= 1.0.2 - Cross-Site Request Forgery to Settings Update","description":"The WP2HTML plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.2. This is due to missing or incorrect nonce validation on the save() function. This makes it possible for unauthenticated attackers to update plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2025-06-13T01:47:48.918Z","updatedAt":"2026-04-08T17:14:50.177Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["digitalacornjp WP2HTML"],"affected":[{"vendor":"digitalacornjp","product":"WP2HTML","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/ac34e369-de9e-4b13-8858-0b4300aef5f8?source=cve","https://plugins.trac.wordpress.org/changeset/3339090/"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:09:39.787Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/5xxx/CVE-2025-5930.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-5930","state":"PUBLISHED","datePublished":"2025-06-13T01:47:48.918Z","dateUpdated":"2026-04-08T17:14:50.177Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-06-09T14:46:26.544Z"},"containers":{"cna":{"title":"WP2HTML <= 1.0.2 - Cross-Site Request Forgery to Settings Update","descriptions":[{"lang":"en","value":"The WP2HTML plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.2. This is due to missing or incorrect nonce validation on the save() function. This makes it possible for unauthenticated attackers to update plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"digitalacornjp","product":"WP2HTML","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/ac34e369-de9e-4b13-8858-0b4300aef5f8?source=cve"},{"url":"https://plugins.trac.wordpress.org/changeset/3339090/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:14:50.177Z"},"credits":[{"lang":"en","type":"finder","value":"Nabil Irawan"}],"timeline":[{"time":"2025-06-12T13:08:43.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-06-13T14:03:04.518179Z","id":"CVE-2025-5930","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-06-13T14:03:11.421Z"}}]}}}