{"id":"CVE-2025-59041","state":"PUBLISHED","title":"Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email","description":"Claude Code is an agentic coding tool. At startup, Claude Code executed a command templated in with `git config user.email`. Prior to version 1.0.105, a maliciously configured user email in git could be used to trigger arbitrary code execution before a user accepted the workspace trust dialog. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.","publishedAt":"2025-09-10T15:07:50.396Z","updatedAt":"2025-10-15T16:00:49.872Z","severity":{"score":8.7,"label":"High","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["anthropics claude-code"],"affected":[{"vendor":"anthropics","product":"claude-code","versions":[{"version":"< 1.0.105","status":"affected"}]}],"references":["https://github.com/anthropics/claude-code/security/advisories/GHSA-j4h9-wv2m-wrf7"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:09:39.787Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/59xxx/CVE-2025-59041.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-59041","state":"PUBLISHED","datePublished":"2025-09-10T15:07:50.396Z","dateUpdated":"2025-10-15T16:00:49.872Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-09-08T16:19:26.171Z"},"containers":{"cna":{"title":"Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email","descriptions":[{"lang":"en","value":"Claude Code is an agentic coding tool. At startup, Claude Code executed a command templated in with `git config user.email`. Prior to version 1.0.105, a maliciously configured user email in git could be used to trigger arbitrary code execution before a user accepted the workspace trust dialog. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version."}],"affected":[{"vendor":"anthropics","product":"claude-code","versions":[{"version":"< 1.0.105","status":"affected"}]}],"references":[{"url":"https://github.com/anthropics/claude-code/security/advisories/GHSA-j4h9-wv2m-wrf7","name":"https://github.com/anthropics/claude-code/security/advisories/GHSA-j4h9-wv2m-wrf7","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"PASSIVE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnAvailabilityImpact":"HIGH","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":8.7,"baseSeverity":"HIGH","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94: Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-09-10T15:07:50.396Z"},"source":{"advisory":"GHSA-j4h9-wv2m-wrf7","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-10-15T16:00:32.713619Z","id":"CVE-2025-59041","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-10-15T16:00:49.872Z"}}]}}}