{"id":"CVE-2025-58175","state":"PUBLISHED","title":"GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution","description":"GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a GeoServer that uses `ENTITY_RESOLUTION_ALLOWLIST` may allow attacker to perform unauthenticated Server-Side Request Forgery (SSRF). This vulnerability requires that GeoServer is set up to use a proxy base URL and the `ENTITY_RESOLUTION_ALLOWLIST` (default since 2.25.0). Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations are only affected by this vulnerability if they use a proxy base URL that does not contain a URL path or end with a slash. If the proxy base URL does not contain a path, adding a slash to the end of the URL will mitigate this vulnerability.","publishedAt":"2026-06-18T14:31:19.757Z","updatedAt":"2026-06-18T15:26:07.311Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:L","source":"GitHub_M"},"assigner":"GitHub_M","products":["geoserver org.geoserver.web:gs-web-app","geoserver org.geoserver:gs-main"],"affected":[{"vendor":"geoserver","product":"org.geoserver.web:gs-web-app","versions":[{"version":"< 2.26.4","status":"affected"},{"version":">= 2.27.0, < 2.27.3","status":"affected"}]},{"vendor":"geoserver","product":"org.geoserver:gs-main","versions":[{"version":"< 2.26.4","status":"affected"},{"version":">= 2.27.0, < 2.27.3","status":"affected"}]}],"references":["https://github.com/geoserver/geoserver/security/advisories/GHSA-x4r9-gmw3-hxww","https://github.com/geoserver/geoserver/pull/8622","https://osgeo-org.atlassian.net/browse/GEOS-11867"],"weaknesses":["CWE-20","CWE-611","CWE-918"],"ingestedAt":"2026-10-29T20:09:39.787Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/58xxx/CVE-2025-58175.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-58175","state":"PUBLISHED","datePublished":"2026-06-18T14:31:19.757Z","dateUpdated":"2026-06-18T15:26:07.311Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-08-27T13:34:56.189Z"},"containers":{"cna":{"title":"GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution","descriptions":[{"lang":"en","value":"GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a GeoServer that uses `ENTITY_RESOLUTION_ALLOWLIST` may allow attacker to perform unauthenticated Server-Side Request Forgery (SSRF). This vulnerability requires that GeoServer is set up to use a proxy base URL and the `ENTITY_RESOLUTION_ALLOWLIST` (default since 2.25.0). Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations are only affected by this vulnerability if they use a proxy base URL that does not contain a URL path or end with a slash. If the proxy base URL does not contain a path, adding a slash to the end of the URL will mitigate this vulnerability."}],"affected":[{"vendor":"geoserver","product":"org.geoserver.web:gs-web-app","versions":[{"version":"< 2.26.4","status":"affected"},{"version":">= 2.27.0, < 2.27.3","status":"affected"}]},{"vendor":"geoserver","product":"org.geoserver:gs-main","versions":[{"version":"< 2.26.4","status":"affected"},{"version":">= 2.27.0, < 2.27.3","status":"affected"}]}],"references":[{"url":"https://github.com/geoserver/geoserver/security/advisories/GHSA-x4r9-gmw3-hxww","name":"https://github.com/geoserver/geoserver/security/advisories/GHSA-x4r9-gmw3-hxww","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/geoserver/geoserver/pull/8622","name":"https://github.com/geoserver/geoserver/pull/8622","tags":["x_refsource_MISC"]},{"url":"https://osgeo-org.atlassian.net/browse/GEOS-11867","name":"https://osgeo-org.atlassian.net/browse/GEOS-11867","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":6.5,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:L","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-20","lang":"en","description":"CWE-20: Improper Input Validation","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-611","lang":"en","description":"CWE-611: Improper Restriction of XML External Entity Reference","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-918","lang":"en","description":"CWE-918: Server-Side Request Forgery (SSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2026-06-18T14:31:19.757Z"},"source":{"advisory":"GHSA-x4r9-gmw3-hxww","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-06-18T15:25:52.864367Z","id":"CVE-2025-58175","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-06-18T15:26:07.311Z"}}]}}}