{"id":"CVE-2025-58064","state":"PUBLISHED","title":"CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package","description":"CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.","publishedAt":"2025-09-03T22:02:53.296Z","updatedAt":"2025-09-04T20:03:46.927Z","severity":{"score":2.3,"label":"Low","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["ckeditor ckeditor5"],"affected":[{"vendor":"ckeditor","product":"ckeditor5","versions":[{"version":">= 46.0.0, < 46.0.3","status":"affected"},{"version":">= 44.2.0, < 45.2.2","status":"affected"}]}],"references":["https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-x9gp-vjh6-3wv6","https://github.com/ckeditor/ckeditor5/commit/b210e90c6cf84e662ef6c7daf93a92355a961bf2"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:09:39.787Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/58xxx/CVE-2025-58064.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-58064","state":"PUBLISHED","datePublished":"2025-09-03T22:02:53.296Z","dateUpdated":"2025-09-04T20:03:46.927Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-08-22T14:30:32.222Z"},"containers":{"cna":{"title":"CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package","descriptions":[{"lang":"en","value":"CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard."}],"affected":[{"vendor":"ckeditor","product":"ckeditor5","versions":[{"version":">= 46.0.0, < 46.0.3","status":"affected"},{"version":">= 44.2.0, < 45.2.2","status":"affected"}]}],"references":[{"url":"https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-x9gp-vjh6-3wv6","name":"https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-x9gp-vjh6-3wv6","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/ckeditor/ckeditor5/commit/b210e90c6cf84e662ef6c7daf93a92355a961bf2","name":"https://github.com/ckeditor/ckeditor5/commit/b210e90c6cf84e662ef6c7daf93a92355a961bf2","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"LOW","attackRequirements":"PRESENT","privilegesRequired":"NONE","userInteraction":"PASSIVE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","vulnAvailabilityImpact":"NONE","subConfidentialityImpact":"NONE","subIntegrityImpact":"LOW","subAvailabilityImpact":"NONE","baseScore":2.3,"baseSeverity":"LOW","vectorString":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-09-03T22:02:53.296Z"},"source":{"advisory":"GHSA-x9gp-vjh6-3wv6","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-04T20:03:38.774462Z","id":"CVE-2025-58064","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-09-04T20:03:46.927Z"}}]}}}