{"id":"CVE-2025-57902","state":"PUBLISHED","title":"WordPress RIS Version Switcher – Downgrade or Upgrade WP Versions Easily Plugin <= 1.0 - Cross Site Request Forgery (CSRF) Vulnerability","description":"Cross-Site Request Forgery (CSRF) vulnerability in Md Taufiqur Rahman RIS Version Switcher – Downgrade or Upgrade WP Versions Easily ris-version-switcher allows Cross Site Request Forgery.This issue affects RIS Version Switcher – Downgrade or Upgrade WP Versions Easily: from n/a through <= 1.0.","publishedAt":"2025-09-22T18:25:26.671Z","updatedAt":"2026-04-28T16:13:37.964Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","source":"Patchstack"},"assigner":"Patchstack","products":["Md Taufiqur Rahman RIS Version Switcher – Downgrade or Upgrade WP Versions Easily"],"affected":[{"vendor":"Md Taufiqur Rahman","product":"RIS Version Switcher – Downgrade or Upgrade WP Versions Easily","packageName":"ris-version-switcher","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0","versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":["https://patchstack.com/database/Wordpress/Plugin/ris-version-switcher/vulnerability/wordpress-ris-version-switcher-downgrade-or-upgrade-wp-versions-easily-plugin-1-0-cross-site-request-forgery-csrf-vulnerability?_s_id=cve"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T20:09:39.787Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/57xxx/CVE-2025-57902.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-57902","state":"PUBLISHED","datePublished":"2025-09-22T18:25:26.671Z","dateUpdated":"2026-04-28T16:13:37.964Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2025-08-22T11:35:51.303Z"},"containers":{"cna":{"title":"WordPress RIS Version Switcher – Downgrade or Upgrade WP Versions Easily Plugin <= 1.0 - Cross Site Request Forgery (CSRF) Vulnerability","descriptions":[{"lang":"en","value":"Cross-Site Request Forgery (CSRF) vulnerability in Md Taufiqur Rahman RIS Version Switcher – Downgrade or Upgrade WP Versions Easily ris-version-switcher allows Cross Site Request Forgery.This issue affects RIS Version Switcher – Downgrade or Upgrade WP Versions Easily: from n/a through <= 1.0."}],"affected":[{"vendor":"Md Taufiqur Rahman","product":"RIS Version Switcher – Downgrade or Upgrade WP Versions Easily","packageName":"ris-version-switcher","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0","versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":[{"url":"https://patchstack.com/database/Wordpress/Plugin/ris-version-switcher/vulnerability/wordpress-ris-version-switcher-downgrade-or-upgrade-wp-versions-easily-plugin-1-0-cross-site-request-forgery-csrf-vulnerability?_s_id=cve","tags":["vdb-entry"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.5,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","description":"Cross-Site Request Forgery (CSRF)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:13:37.964Z"},"credits":[{"lang":"en","type":"finder","value":"johska | Patchstack Bug Bounty Program"}],"datePublic":"2026-04-01T16:42:32.449Z","impacts":[{"capecId":"CAPEC-62","descriptions":[{"lang":"en","value":"Cross Site Request Forgery"}]}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-23T20:31:10.988107Z","id":"CVE-2025-57902","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-09-23T20:31:18.276Z"}}]}}}