{"id":"CVE-2025-54417","state":"PUBLISHED","title":"Craft contains a theoretical bypass for CVE-2025-23209","description":"Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: \"Craft CMS has a potential RCE with a compromised security key\". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.","publishedAt":"2025-08-09T01:31:23.974Z","updatedAt":"2025-08-11T13:38:51.609Z","severity":{"score":5.2,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","source":"GitHub_M"},"assigner":"GitHub_M","products":["craftcms cms"],"affected":[{"vendor":"craftcms","product":"cms","versions":[{"version":">= 4.13.8, < 4.16.3","status":"affected"},{"version":">= 5.5.8, < 5.8.4","status":"affected"}]}],"references":["https://github.com/craftcms/cms/security/advisories/GHSA-2vcf-qxv3-2mgw","https://github.com/craftcms/cms/commit/a19d46be78a9ca1ea474012a10e97bed0d787f57"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T20:09:31.862Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/54xxx/CVE-2025-54417.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-54417","state":"PUBLISHED","datePublished":"2025-08-09T01:31:23.974Z","dateUpdated":"2025-08-11T13:38:51.609Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-07-21T23:18:10.281Z"},"containers":{"cna":{"title":"Craft contains a theoretical bypass for CVE-2025-23209","descriptions":[{"lang":"en","value":"Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: \"Craft CMS has a potential RCE with a compromised security key\". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4."}],"affected":[{"vendor":"craftcms","product":"cms","versions":[{"version":">= 4.13.8, < 4.16.3","status":"affected"},{"version":">= 5.5.8, < 5.8.4","status":"affected"}]}],"references":[{"url":"https://github.com/craftcms/cms/security/advisories/GHSA-2vcf-qxv3-2mgw","name":"https://github.com/craftcms/cms/security/advisories/GHSA-2vcf-qxv3-2mgw","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/craftcms/cms/commit/a19d46be78a9ca1ea474012a10e97bed0d787f57","name":"https://github.com/craftcms/cms/commit/a19d46be78a9ca1ea474012a10e97bed0d787f57","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"HIGH","attackRequirements":"NONE","privilegesRequired":"LOW","userInteraction":"NONE","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnAvailabilityImpact":"HIGH","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":5.2,"baseSeverity":"MEDIUM","vectorString":"CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","lang":"en","description":"CWE-94: Improper Control of Generation of Code ('Code Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-08-09T01:31:23.974Z"},"source":{"advisory":"GHSA-2vcf-qxv3-2mgw","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-08-11T13:38:12.800909Z","id":"CVE-2025-54417","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-08-11T13:38:51.609Z"}}]}}}