{"id":"CVE-2025-53689","state":"PUBLISHED","title":"Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons","description":"Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges.\n\nUsers are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.","publishedAt":"2025-07-14T09:15:38.863Z","updatedAt":"2025-11-04T21:12:33.255Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"CISA-ADP"},"assigner":"apache","products":["Apache Software Foundation Apache Jackrabbit"],"affected":[{"vendor":"Apache Software Foundation","product":"Apache Jackrabbit","packageName":"org.apache.jackrabbit:jackrabbit-spi-commons","defaultStatus":"unaffected","versions":[{"version":"2.20.0","status":"affected","lessThan":"2.20.17","versionType":"maven"},{"version":"2.22.0","status":"affected","lessThan":"2.22.1","versionType":"maven"},{"version":"2.23.0-beta","status":"affected","lessThan":"2.23.2-beta","versionType":"maven"}]}],"references":["https://lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24","http://www.openwall.com/lists/oss-security/2025/07/14/1"],"weaknesses":["CWE-611"],"ingestedAt":"2026-10-29T20:09:31.862Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/53xxx/CVE-2025-53689.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-53689","state":"PUBLISHED","datePublished":"2025-07-14T09:15:38.863Z","dateUpdated":"2025-11-04T21:12:33.255Z","assignerShortName":"apache","assignerOrgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","dateReserved":"2025-07-08T10:21:17.361Z"},"containers":{"cna":{"title":"Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons","descriptions":[{"lang":"en","value":"Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges.\n\nUsers are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version."}],"affected":[{"vendor":"Apache Software Foundation","product":"Apache Jackrabbit","packageName":"org.apache.jackrabbit:jackrabbit-spi-commons","defaultStatus":"unaffected","versions":[{"version":"2.20.0","status":"affected","lessThan":"2.20.17","versionType":"maven"},{"version":"2.22.0","status":"affected","lessThan":"2.22.1","versionType":"maven"},{"version":"2.23.0-beta","status":"affected","lessThan":"2.23.2-beta","versionType":"maven"}]}],"references":[{"url":"https://lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24","tags":["vendor-advisory"]}],"metrics":[{"other":{"content":{"text":"critical"},"type":"Textual description of severity"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-611","description":"CWE-611 Improper Restriction of XML External Entity Reference","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"apache","orgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","dateUpdated":"2025-07-14T09:15:38.863Z"},"credits":[{"lang":"en","type":"reporter","value":"Lars Krapf - Adobe"},{"lang":"en","type":"finder","value":"Dylan Pindur - Assetnote"},{"lang":"en","type":"finder","value":"Adam Kues - Assetnote"}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"cvssV3_1":{"scope":"UNCHANGED","version":"3.1","baseScore":8.8,"attackVector":"NETWORK","baseSeverity":"HIGH","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","integrityImpact":"HIGH","userInteraction":"NONE","attackComplexity":"LOW","availabilityImpact":"HIGH","privilegesRequired":"LOW","confidentialityImpact":"HIGH"}},{"other":{"type":"ssvc","content":{"timestamp":"2025-07-14T15:45:32.467940Z","id":"CVE-2025-53689","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-07-14T15:46:20.206Z"}},{"title":"CVE Program Container","references":[{"url":"http://www.openwall.com/lists/oss-security/2025/07/14/1"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-11-04T21:12:33.255Z"}}]}}}