{"id":"CVE-2025-5116","state":"PUBLISHED","title":"WP Plugin Info Card <= 5.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via containerid Parameter","description":"The WP Plugin Info Card plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘containerid’ parameter in all versions up to, and including, 5.3.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This issue is due to an incomplete patch for CVE-2025-31835.","publishedAt":"2025-06-03T08:21:53.834Z","updatedAt":"2026-04-08T17:29:15.584Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["brikou WP Plugin Info Card"],"affected":[{"vendor":"brikou","product":"WP Plugin Info Card","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.3.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/e29ea7dd-14b8-45d3-a87e-3f58de88af4c?source=cve","https://plugins.trac.wordpress.org/browser/wp-plugin-info-card/trunk/php/Shortcodes.php#L929","https://wordpress.org/plugins/wp-plugin-info-card/#developers","https://plugins.trac.wordpress.org/changeset/3303791","https://github.com/DLXPlugins/wp-plugin-info-card/blob/dev/php/Shortcodes.php#L893"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:09:39.787Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/5xxx/CVE-2025-5116.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-5116","state":"PUBLISHED","datePublished":"2025-06-03T08:21:53.834Z","dateUpdated":"2026-04-08T17:29:15.584Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-05-23T10:27:37.200Z"},"containers":{"cna":{"title":"WP Plugin Info Card <= 5.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via containerid Parameter","descriptions":[{"lang":"en","value":"The WP Plugin Info Card plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘containerid’ parameter in all versions up to, and including, 5.3.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This issue is due to an incomplete patch for CVE-2025-31835."}],"affected":[{"vendor":"brikou","product":"WP Plugin Info Card","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.3.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/e29ea7dd-14b8-45d3-a87e-3f58de88af4c?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wp-plugin-info-card/trunk/php/Shortcodes.php#L929"},{"url":"https://wordpress.org/plugins/wp-plugin-info-card/#developers"},{"url":"https://plugins.trac.wordpress.org/changeset/3303791"},{"url":"https://github.com/DLXPlugins/wp-plugin-info-card/blob/dev/php/Shortcodes.php#L893"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:29:15.584Z"},"credits":[{"lang":"en","type":"finder","value":"Peter Thaleikis"}],"timeline":[{"time":"2025-06-02T19:43:12.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-06-03T13:29:40.359802Z","id":"CVE-2025-5116","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-06-03T13:29:52.353Z"}}]}}}