{"id":"CVE-2025-47780","state":"PUBLISHED","title":"cli_permissions.conf: deny option does not work for disallowing shell commands","description":"Asterisk is an open-source private branch exchange (PBX). Prior to versions 18.26.2, 20.14.1, 21.9.1, and 22.4.1 of Asterisk and versions 18.9-cert14 and 20.7-cert5 of certified-asterisk, trying to disallow shell commands to be run via the Asterisk command line interface (CLI) by configuring `cli_permissions.conf` (e.g. with the config line `deny=!*`) does not work which could lead to a security risk. If an administrator running an Asterisk instance relies on the `cli_permissions.conf` file to work and expects it to deny all attempts to execute shell commands, then this could lead to a security vulnerability. Versions 18.26.2, 20.14.1, 21.9.1, and 22.4.1 of Asterisk and versions 18.9-cert14 and 20.7-cert5 of certified-asterisk fix the issue.","publishedAt":"2025-05-22T16:56:28.937Z","updatedAt":"2025-11-03T20:04:38.254Z","severity":{"score":4.8,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["asterisk asterisk"],"affected":[{"vendor":"asterisk","product":"asterisk","versions":[{"version":"< 18.9-cert14","status":"affected"},{"version":">= 18.10, < 18.26.2","status":"affected"},{"version":">= 20.0, < 20.7-cert5","status":"affected"},{"version":">= 20.8, < 20.14.1","status":"affected"},{"version":">= 21.0, < 21.9.1","status":"affected"},{"version":">= 22.0, < 22.4.1","status":"affected"}]}],"references":["https://github.com/asterisk/asterisk/security/advisories/GHSA-c7p6-7mvq-8jq2","https://lists.debian.org/debian-lts-announce/2025/06/msg00003.html"],"weaknesses":["CWE-78"],"ingestedAt":"2026-10-29T20:09:23.771Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/47xxx/CVE-2025-47780.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-47780","state":"PUBLISHED","datePublished":"2025-05-22T16:56:28.937Z","dateUpdated":"2025-11-03T20:04:38.254Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-05-09T19:49:35.620Z"},"containers":{"cna":{"title":"cli_permissions.conf: deny option does not work for disallowing shell commands","descriptions":[{"lang":"en","value":"Asterisk is an open-source private branch exchange (PBX). Prior to versions 18.26.2, 20.14.1, 21.9.1, and 22.4.1 of Asterisk and versions 18.9-cert14 and 20.7-cert5 of certified-asterisk, trying to disallow shell commands to be run via the Asterisk command line interface (CLI) by configuring `cli_permissions.conf` (e.g. with the config line `deny=!*`) does not work which could lead to a security risk. If an administrator running an Asterisk instance relies on the `cli_permissions.conf` file to work and expects it to deny all attempts to execute shell commands, then this could lead to a security vulnerability. Versions 18.26.2, 20.14.1, 21.9.1, and 22.4.1 of Asterisk and versions 18.9-cert14 and 20.7-cert5 of certified-asterisk fix the issue."}],"affected":[{"vendor":"asterisk","product":"asterisk","versions":[{"version":"< 18.9-cert14","status":"affected"},{"version":">= 18.10, < 18.26.2","status":"affected"},{"version":">= 20.0, < 20.7-cert5","status":"affected"},{"version":">= 20.8, < 20.14.1","status":"affected"},{"version":">= 21.0, < 21.9.1","status":"affected"},{"version":">= 22.0, < 22.4.1","status":"affected"}]}],"references":[{"url":"https://github.com/asterisk/asterisk/security/advisories/GHSA-c7p6-7mvq-8jq2","name":"https://github.com/asterisk/asterisk/security/advisories/GHSA-c7p6-7mvq-8jq2","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV4_0":{"attackVector":"LOCAL","attackComplexity":"LOW","attackRequirements":"NONE","privilegesRequired":"LOW","userInteraction":"NONE","vulnConfidentialityImpact":"LOW","vulnIntegrityImpact":"LOW","vulnAvailabilityImpact":"LOW","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","subAvailabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","vectorString":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-78","lang":"en","description":"CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-05-22T16:56:28.937Z"},"source":{"advisory":"GHSA-c7p6-7mvq-8jq2","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-05-22T17:24:44.875844Z","id":"CVE-2025-47780","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-22T17:25:09.045Z"}},{"title":"CVE Program Container","references":[{"url":"https://lists.debian.org/debian-lts-announce/2025/06/msg00003.html"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-11-03T20:04:38.254Z"}}]}}}