{"id":"CVE-2025-4682","state":"PUBLISHED","title":"Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates <= 5.4.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Slider and Post Carousel Widgets","description":"The Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via HTML attributes in Slider and Post Carousel widgets in all versions up to, and including, 5.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-05-27T01:48:48.934Z","updatedAt":"2026-04-08T17:33:58.758Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["wpdevteam Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns"],"affected":[{"vendor":"wpdevteam","product":"Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.4.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/f88f065d-14ca-4547-9a41-f9177979a9ed?source=cve","https://plugins.trac.wordpress.org/browser/essential-blocks/tags/5.4.0/src/blocks/slider/src/frontend.js","https://plugins.trac.wordpress.org/browser/essential-blocks/tags/5.4.0/src/blocks/post-carousel/src/frontend.js","https://plugins.trac.wordpress.org/changeset/3296386/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:09:23.771Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/4xxx/CVE-2025-4682.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-4682","state":"PUBLISHED","datePublished":"2025-05-27T01:48:48.934Z","dateUpdated":"2026-04-08T17:33:58.758Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-05-14T10:35:43.357Z"},"containers":{"cna":{"title":"Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates <= 5.4.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Slider and Post Carousel Widgets","descriptions":[{"lang":"en","value":"The Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via HTML attributes in Slider and Post Carousel widgets in all versions up to, and including, 5.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"wpdevteam","product":"Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"5.4.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/f88f065d-14ca-4547-9a41-f9177979a9ed?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/essential-blocks/tags/5.4.0/src/blocks/slider/src/frontend.js"},{"url":"https://plugins.trac.wordpress.org/browser/essential-blocks/tags/5.4.0/src/blocks/post-carousel/src/frontend.js"},{"url":"https://plugins.trac.wordpress.org/changeset/3296386/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:33:58.758Z"},"credits":[{"lang":"en","type":"finder","value":"Craig Smith"}],"timeline":[{"time":"2025-05-10T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2025-05-26T12:53:47.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-05-27T19:55:04.196579Z","id":"CVE-2025-4682","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-27T19:55:21.037Z"}}]}}}