{"id":"CVE-2025-4638","state":"PUBLISHED","title":"Improper Pointer Arithmetic in pcl","description":"A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic.\n\nSince version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.","publishedAt":"2025-05-14T17:59:58.180Z","updatedAt":"2025-05-15T13:49:10.296Z","severity":{"score":9.2,"label":"Critical","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:L/SA:H/AU:Y/R:U/V:D/RE:M/U:Amber","source":"GovTech CSG"},"assigner":"GovTech CSG","products":["PointCloudLibrary pcl"],"affected":[{"vendor":"PointCloudLibrary","product":"pcl","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"<1.15.0","changes":[{"at":"patch 1.15.0","status":"unaffected"}],"versionType":"git"}]}],"references":["https://github.com/PointCloudLibrary/pcl/pull/6245","https://github.com/PointCloudLibrary/pcl/blob/master/surface/CMakeLists.txt#L70","https://github.com/PointCloudLibrary/pcl/commit/502bd2b013ce635f21632d523aa8cf2e04f7b7ac"],"weaknesses":["CWE-119"],"ingestedAt":"2026-10-29T20:09:23.771Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/4xxx/CVE-2025-4638.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-4638","state":"PUBLISHED","datePublished":"2025-05-14T17:59:58.180Z","dateUpdated":"2025-05-15T13:49:10.296Z","assignerShortName":"GovTech CSG","assignerOrgId":"1a37b84a-8e51-4525-b3d6-87e2fae01dbd","dateReserved":"2025-05-13T02:36:24.908Z"},"containers":{"cna":{"title":"Improper Pointer Arithmetic in pcl","descriptions":[{"lang":"en","value":"A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic.\n\nSince version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib."}],"affected":[{"vendor":"PointCloudLibrary","product":"pcl","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"<1.15.0","changes":[{"at":"patch 1.15.0","status":"unaffected"}],"versionType":"git"}]}],"references":[{"url":"https://github.com/PointCloudLibrary/pcl/pull/6245","tags":["patch"]},{"url":"https://github.com/PointCloudLibrary/pcl/blob/master/surface/CMakeLists.txt#L70"},{"url":"https://github.com/PointCloudLibrary/pcl/commit/502bd2b013ce635f21632d523aa8cf2e04f7b7ac"}],"metrics":[{"cvssV4_0":{"Automatable":"YES","Recovery":"USER","Safety":"NOT_DEFINED","attackComplexity":"LOW","attackRequirements":"NONE","attackVector":"NETWORK","baseScore":9.2,"baseSeverity":"CRITICAL","privilegesRequired":"NONE","providerUrgency":"AMBER","subAvailabilityImpact":"HIGH","subConfidentialityImpact":"NONE","subIntegrityImpact":"LOW","userInteraction":"NONE","valueDensity":"DIFFUSE","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:H/SC:N/SI:L/SA:H/AU:Y/R:U/V:D/RE:M/U:Amber","version":"4.0","vulnAvailabilityImpact":"HIGH","vulnConfidentialityImpact":"LOW","vulnIntegrityImpact":"HIGH","vulnerabilityResponseEffort":"MODERATE"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"providerMetadata":{"shortName":"GovTech CSG","orgId":"1a37b84a-8e51-4525-b3d6-87e2fae01dbd","dateUpdated":"2025-05-14T17:59:58.180Z"},"credits":[{"lang":"en","type":"reporter","value":"TITAN Team (titancaproject@gmail.com)"}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-05-15T13:48:23.859989Z","id":"CVE-2025-4638","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-119","type":"CWE","lang":"en","description":"CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-15T13:49:10.296Z"}}]}}}