{"id":"CVE-2025-4579","state":"PUBLISHED","title":"WP Content Security Plugin <= 2.3 - Unauthenticated Stored Cross-Site Scripting via CSP-Report Fields","description":"The WP Content Security Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the blocked-uri and effective-directive  parameters in all versions up to, and including, 2.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-05-15T01:59:23.874Z","updatedAt":"2026-04-08T17:32:57.747Z","severity":{"score":7.2,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["dyland WP Content Security Plugin"],"affected":[{"vendor":"dyland","product":"WP Content Security Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.3","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/f3c4ba08-a9fa-439a-a887-b8c113f78e20?source=cve","https://plugins.trac.wordpress.org/browser/wp-content-security-policy/tags/2.3/includes/WP_CSP.php#L597","https://plugins.trac.wordpress.org/browser/wp-content-security-policy/tags/2.3/includes/WP_CSP.php#L612","https://plugins.trac.wordpress.org/browser/wp-content-security-policy/tags/2.3/includes/WP_CSP.php#L659"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:09:23.771Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/4xxx/CVE-2025-4579.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-4579","state":"PUBLISHED","datePublished":"2025-05-15T01:59:23.874Z","dateUpdated":"2026-04-08T17:32:57.747Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-05-12T13:01:11.410Z"},"containers":{"cna":{"title":"WP Content Security Plugin <= 2.3 - Unauthenticated Stored Cross-Site Scripting via CSP-Report Fields","descriptions":[{"lang":"en","value":"The WP Content Security Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the blocked-uri and effective-directive  parameters in all versions up to, and including, 2.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"dyland","product":"WP Content Security Plugin","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"2.3","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/f3c4ba08-a9fa-439a-a887-b8c113f78e20?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/wp-content-security-policy/tags/2.3/includes/WP_CSP.php#L597"},{"url":"https://plugins.trac.wordpress.org/browser/wp-content-security-policy/tags/2.3/includes/WP_CSP.php#L612"},{"url":"https://plugins.trac.wordpress.org/browser/wp-content-security-policy/tags/2.3/includes/WP_CSP.php#L659"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","baseScore":7.2,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:32:57.747Z"},"credits":[{"lang":"en","type":"finder","value":"anhchangmutrang"}],"timeline":[{"time":"2025-05-12T00:00:00.000Z","lang":"en","value":"Discovered"},{"time":"2025-05-14T13:58:22.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-05-15T14:31:21.566930Z","id":"CVE-2025-4579","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-15T14:40:33.536Z"}}]}}}