{"id":"CVE-2025-3880","state":"PUBLISHED","title":"Poll, Survey & Quiz Maker Plugin by Opinion Stage <= 19.9.0 - Incorrect Authorization to Authenticated (Contributor+) Plugin Settings Update","description":"The Poll, Survey & Quiz Maker Plugin by Opinion Stage plugin for WordPress is vulnerable to unauthorized modification of data due to a misconfigured capability check on several functions in all versions up to, and including, 19.9.0. This makes it possible for authenticated attackers, with Contributor-level access and above, to change the email address for the account connection, and disconnect the plugin. Previously created content will still be displayed and functional if the account is disconnected.","publishedAt":"2025-06-17T11:23:36.813Z","updatedAt":"2026-04-08T17:18:16.170Z","severity":{"score":4.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["assafp Quiz, Poll & Survey Maker by Opinion Stage"],"affected":[{"vendor":"assafp","product":"Quiz, Poll & Survey Maker by Opinion Stage","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"19.9.0","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/ba86268a-7bd6-40ed-9af6-29409245675d?source=cve","https://plugins.trac.wordpress.org/browser/social-polls-by-opinionstage/trunk/plugin.php","https://plugins.trac.wordpress.org/browser/social-polls-by-opinionstage/trunk/src/Modules/Admin.php","https://plugins.trac.wordpress.org/changeset/3310848/"],"weaknesses":["CWE-863"],"ingestedAt":"2026-10-29T20:09:09.358Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/3xxx/CVE-2025-3880.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-3880","state":"PUBLISHED","datePublished":"2025-06-17T11:23:36.813Z","dateUpdated":"2026-04-08T17:18:16.170Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-04-22T19:41:16.892Z"},"containers":{"cna":{"title":"Poll, Survey & Quiz Maker Plugin by Opinion Stage <= 19.9.0 - Incorrect Authorization to Authenticated (Contributor+) Plugin Settings Update","descriptions":[{"lang":"en","value":"The Poll, Survey & Quiz Maker Plugin by Opinion Stage plugin for WordPress is vulnerable to unauthorized modification of data due to a misconfigured capability check on several functions in all versions up to, and including, 19.9.0. This makes it possible for authenticated attackers, with Contributor-level access and above, to change the email address for the account connection, and disconnect the plugin. Previously created content will still be displayed and functional if the account is disconnected."}],"affected":[{"vendor":"assafp","product":"Quiz, Poll & Survey Maker by Opinion Stage","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"19.9.0","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/ba86268a-7bd6-40ed-9af6-29409245675d?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/social-polls-by-opinionstage/trunk/plugin.php"},{"url":"https://plugins.trac.wordpress.org/browser/social-polls-by-opinionstage/trunk/src/Modules/Admin.php"},{"url":"https://plugins.trac.wordpress.org/changeset/3310848/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","baseScore":4.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-863","lang":"en","description":"CWE-863 Incorrect Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:18:16.170Z"},"credits":[{"lang":"en","type":"finder","value":"Amin Beheshti"}],"timeline":[{"time":"2025-06-16T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-06-17T14:01:37.438964Z","id":"CVE-2025-3880","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-06-17T14:10:35.433Z"}}]}}}