{"id":"CVE-2025-3750","state":"PUBLISHED","title":"Network Posts Extended <= 7.7.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via post_height Parameter","description":"The Network Posts Extended plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘post_height’ parameter in all versions up to, and including, 7.7.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","publishedAt":"2025-05-21T09:21:51.056Z","updatedAt":"2026-04-08T16:57:37.155Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["johnzenausa Network Posts Extended"],"affected":[{"vendor":"johnzenausa","product":"Network Posts Extended","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.7.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/64a15397-0bd6-4be9-90e3-6cb1f56394ad?source=cve","https://plugins.trac.wordpress.org/browser/network-posts-extended/trunk/network-posts-extended.php#L663","https://wordpress.org/plugins/network-posts-extended/#developers"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T20:09:09.358Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/3xxx/CVE-2025-3750.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-3750","state":"PUBLISHED","datePublished":"2025-05-21T09:21:51.056Z","dateUpdated":"2026-04-08T16:57:37.155Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-04-16T21:00:11.045Z"},"containers":{"cna":{"title":"Network Posts Extended <= 7.7.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via post_height Parameter","descriptions":[{"lang":"en","value":"The Network Posts Extended plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘post_height’ parameter in all versions up to, and including, 7.7.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page."}],"affected":[{"vendor":"johnzenausa","product":"Network Posts Extended","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"7.7.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/64a15397-0bd6-4be9-90e3-6cb1f56394ad?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/network-posts-extended/trunk/network-posts-extended.php#L663"},{"url":"https://wordpress.org/plugins/network-posts-extended/#developers"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","baseScore":6.4,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:57:37.155Z"},"credits":[{"lang":"en","type":"finder","value":"Peter Thaleikis"}],"timeline":[{"time":"2025-05-20T20:30:33.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-05-21T10:11:55.244144Z","id":"CVE-2025-3750","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-21T10:16:59.816Z"}}]}}}