{"id":"CVE-2025-36097","state":"PUBLISHED","title":"IBM WebSphere Application Server denial of service","description":"IBM WebSphere Application Server 9.0 and WebSphere Application Server Liberty 17.0.0.3 through 25.0.0.7 are vulnerable to a denial of service, caused by a stack-based overflow.  An attacker can send a specially crafted request that cause the server to consume excessive memory resources.","publishedAt":"2025-07-16T17:44:14.979Z","updatedAt":"2025-08-18T01:34:17.799Z","severity":{"score":7.5,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","source":"ibm"},"assigner":"ibm","products":["IBM WebSphere Application Server","IBM WebSphere Application Server Liberty"],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","defaultStatus":"unaffected","versions":[{"version":"9.0","status":"affected"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*"]},{"vendor":"IBM","product":"WebSphere Application Server Liberty","defaultStatus":"unaffected","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"25.0.0.7","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:17.0.0.3:*:*:*:liberty:*:*:*","cpe:2.3:a:ibm:websphere_application_server:25.0.0.7:*:*:*:liberty:*:*:*"]}],"references":["https://www.ibm.com/support/pages/node/7239856"],"weaknesses":["CWE-121"],"ingestedAt":"2026-10-29T20:09:03.054Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/36xxx/CVE-2025-36097.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-36097","state":"PUBLISHED","datePublished":"2025-07-16T17:44:14.979Z","dateUpdated":"2025-08-18T01:34:17.799Z","assignerShortName":"ibm","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateReserved":"2025-04-15T21:16:14.712Z"},"containers":{"cna":{"title":"IBM WebSphere Application Server denial of service","descriptions":[{"lang":"en","value":"IBM WebSphere Application Server 9.0 and WebSphere Application Server Liberty 17.0.0.3 through 25.0.0.7 are vulnerable to a denial of service, caused by a stack-based overflow.  An attacker can send a specially crafted request that cause the server to consume excessive memory resources."}],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","defaultStatus":"unaffected","versions":[{"version":"9.0","status":"affected"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*"]},{"vendor":"IBM","product":"WebSphere Application Server Liberty","defaultStatus":"unaffected","versions":[{"version":"17.0.0.3","status":"affected","lessThanOrEqual":"25.0.0.7","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:17.0.0.3:*:*:*:liberty:*:*:*","cpe:2.3:a:ibm:websphere_application_server:25.0.0.7:*:*:*:liberty:*:*:*"]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7239856","tags":["vendor-advisory","patch"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":7.5,"baseSeverity":"HIGH","confidentialityImpact":"NONE","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-121","description":"CWE-121 Stack-based Buffer Overflow","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"ibm","orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateUpdated":"2025-08-18T01:34:17.799Z"},"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"For IBM WebSphere Application Server Liberty 17.0.0.3 - 25.0.0.7 using the jsonp-1.0, jsonp-1.1, or jsonp-2.0 feature:<br><br>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH67183 <br>--OR--<br>· Apply Fix Pack 25.0.0.8 or later (targeted availability 3Q2025).<br><br>For IBM WebSphere Application Server traditional:<br><br>For V9.0.0.0 through 9.0.5.24:<br>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH67120  <br>--OR--<br>· Apply Fix Pack 9.0.5.25 or later (targeted availability 3Q2025).  <br><br> <br><br>Additional interim fixes may be available and linked off the interim fix download page.<br>"}],"value":"For IBM WebSphere Application Server Liberty 17.0.0.3 - 25.0.0.7 using the jsonp-1.0, jsonp-1.1, or jsonp-2.0 feature:\n\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH67183 \n--OR--\n· Apply Fix Pack 25.0.0.8 or later (targeted availability 3Q2025).\n\nFor IBM WebSphere Application Server traditional:\n\nFor V9.0.0.0 through 9.0.5.24:\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH67120  \n--OR--\n· Apply Fix Pack 9.0.5.25 or later (targeted availability 3Q2025).  \n\n \n\nAdditional interim fixes may be available and linked off the interim fix download page."}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-07-18T14:25:00.413579Z","id":"CVE-2025-36097","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-07-18T14:25:08.468Z"}}]}}}