{"id":"CVE-2025-3438","state":"PUBLISHED","title":"MStore API – Create Native Android & iOS Apps On The Cloud <= 4.17.4 - Unauthenticated Limited Privilege Escalation","description":"The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to limited privilege escalation in all versions up to, and including, 4.17.4. This is due to a lack of restriction of role when registering. This makes it possible for unauthenticated attackers to to register with the 'wcfm_vendor' role, which is a Store Vendor role in the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin for WordPress. The vulnerability can only be exploited if the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin is installed and activated. The vulnerability was partially patched in version 4.17.3.","publishedAt":"2025-05-02T05:22:34.308Z","updatedAt":"2026-04-08T17:19:12.414Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["inspireui MStore API – Create Native Android & iOS Apps On The Cloud"],"affected":[{"vendor":"inspireui","product":"MStore API – Create Native Android & iOS Apps On The Cloud","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.17.4","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/be5d86ad-f94b-4fcb-9b74-ecddde2bf29d?source=cve","https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L392","https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L413","https://plugins.trac.wordpress.org/changeset/3277790","https://plugins.trac.wordpress.org/changeset/3279132/"],"weaknesses":["CWE-269"],"ingestedAt":"2026-10-29T20:09:09.358Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/3xxx/CVE-2025-3438.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-3438","state":"PUBLISHED","datePublished":"2025-05-02T05:22:34.308Z","dateUpdated":"2026-04-08T17:19:12.414Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2025-04-07T21:38:46.671Z"},"containers":{"cna":{"title":"MStore API – Create Native Android & iOS Apps On The Cloud <= 4.17.4 - Unauthenticated Limited Privilege Escalation","descriptions":[{"lang":"en","value":"The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to limited privilege escalation in all versions up to, and including, 4.17.4. This is due to a lack of restriction of role when registering. This makes it possible for unauthenticated attackers to to register with the 'wcfm_vendor' role, which is a Store Vendor role in the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin for WordPress. The vulnerability can only be exploited if the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin is installed and activated. The vulnerability was partially patched in version 4.17.3."}],"affected":[{"vendor":"inspireui","product":"MStore API – Create Native Android & iOS Apps On The Cloud","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"4.17.4","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/be5d86ad-f94b-4fcb-9b74-ecddde2bf29d?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L392"},{"url":"https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L413"},{"url":"https://plugins.trac.wordpress.org/changeset/3277790"},{"url":"https://plugins.trac.wordpress.org/changeset/3279132/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","baseScore":6.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-269","lang":"en","description":"CWE-269 Improper Privilege Management","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:19:12.414Z"},"credits":[{"lang":"en","type":"finder","value":"Brian Sans-Souci"}],"timeline":[{"time":"2025-05-01T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-05-02T15:47:03.172962Z","id":"CVE-2025-3438","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-02T15:47:36.691Z"}}]}}}