{"id":"CVE-2025-34192","state":"PUBLISHED","title":"Vasion Print (formerly PrinterLogic) Usage of Outdated and Unsupported OpenSSL Version","description":"Vasion Print (formerly PrinterLogic) Virtual Appliance Host versions prior to 22.0.893 and Application versions prior to 20.0.2140 (macOS/Linux client deployments) are built against OpenSSL 1.0.2h-fips (released May 2016), which has been end-of-life since 2019 and is no longer supported by the OpenSSL project. Continued use of this outdated cryptographic library exposes deployments to known vulnerabilities that are no longer patched, weakening the overall security posture. Affected daemons may emit deprecation warnings and rely on cryptographic components with unresolved security flaws, potentially enabling attackers to exploit weaknesses in TLS/SSL processing or cryptographic operations. This vulnerability has been identified by the vendor as: V-2023-021 — Out-of-Date OpenSSL Library.","publishedAt":"2025-09-19T18:39:01.020Z","updatedAt":"2026-05-15T11:15:12.535Z","severity":{"score":9.3,"label":"Critical","version":"4.0","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","source":"VulnCheck"},"assigner":"VulnCheck","products":["Vasion Print Virtual Appliance Host","Vasion Print Application"],"affected":[{"vendor":"Vasion","product":"Print Virtual Appliance Host","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"22.0.893","versionType":"semver"}],"modules":["PrinterInstallerClient OpenSSL dependency"],"platforms":["MacOS","Linux"]},{"vendor":"Vasion","product":"Print Application","defaultStatus":"unknown","versions":[{"version":"0","status":"affected","lessThan":"20.0.2140","versionType":"semver"}],"modules":["PrinterInstallerClient OpenSSL dependency"],"platforms":["MacOS","Linux"]}],"references":["https://help.printerlogic.com/saas/Print/Security/Security-Bulletins.htm","https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html#mac-outdated-openssl","https://help.printerlogic.com/va/Print/Security/Security-Bulletins.htm","https://www.vulncheck.com/advisories/vasion-print-printerlogic-usage-of-outdated-and-unsupported-openssl-version"],"weaknesses":["CWE-1104"],"ingestedAt":"2026-10-29T20:09:03.054Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/34xxx/CVE-2025-34192.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-34192","state":"PUBLISHED","datePublished":"2025-09-19T18:39:01.020Z","dateUpdated":"2026-05-15T11:15:12.535Z","assignerShortName":"VulnCheck","assignerOrgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateReserved":"2025-04-15T19:15:22.569Z"},"containers":{"cna":{"title":"Vasion Print (formerly PrinterLogic) Usage of Outdated and Unsupported OpenSSL Version","descriptions":[{"lang":"en","value":"Vasion Print (formerly PrinterLogic) Virtual Appliance Host versions prior to 22.0.893 and Application versions prior to 20.0.2140 (macOS/Linux client deployments) are built against OpenSSL 1.0.2h-fips (released May 2016), which has been end-of-life since 2019 and is no longer supported by the OpenSSL project. Continued use of this outdated cryptographic library exposes deployments to known vulnerabilities that are no longer patched, weakening the overall security posture. Affected daemons may emit deprecation warnings and rely on cryptographic components with unresolved security flaws, potentially enabling attackers to exploit weaknesses in TLS/SSL processing or cryptographic operations. This vulnerability has been identified by the vendor as: V-2023-021 — Out-of-Date OpenSSL Library."}],"affected":[{"vendor":"Vasion","product":"Print Virtual Appliance Host","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"22.0.893","versionType":"semver"}],"modules":["PrinterInstallerClient OpenSSL dependency"],"platforms":["MacOS","Linux"]},{"vendor":"Vasion","product":"Print Application","defaultStatus":"unknown","versions":[{"version":"0","status":"affected","lessThan":"20.0.2140","versionType":"semver"}],"modules":["PrinterInstallerClient OpenSSL dependency"],"platforms":["MacOS","Linux"]}],"references":[{"url":"https://help.printerlogic.com/saas/Print/Security/Security-Bulletins.htm","tags":["vendor-advisory","patch"]},{"url":"https://pierrekim.github.io/blog/2025-04-08-vasion-printerlogic-83-vulnerabilities.html#mac-outdated-openssl","tags":["technical-description"]},{"url":"https://help.printerlogic.com/va/Print/Security/Security-Bulletins.htm","tags":["vendor-advisory","patch"]},{"url":"https://www.vulncheck.com/advisories/vasion-print-printerlogic-usage-of-outdated-and-unsupported-openssl-version","tags":["third-party-advisory"]}],"metrics":[{"cvssV4_0":{"Automatable":"NOT_DEFINED","Recovery":"NOT_DEFINED","Safety":"NOT_DEFINED","attackComplexity":"LOW","attackRequirements":"NONE","attackVector":"NETWORK","baseScore":9.3,"baseSeverity":"CRITICAL","privilegesRequired":"NONE","providerUrgency":"NOT_DEFINED","subAvailabilityImpact":"NONE","subConfidentialityImpact":"NONE","subIntegrityImpact":"NONE","userInteraction":"NONE","valueDensity":"NOT_DEFINED","vectorString":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0","vulnAvailabilityImpact":"HIGH","vulnConfidentialityImpact":"HIGH","vulnIntegrityImpact":"HIGH","vulnerabilityResponseEffort":"NOT_DEFINED"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-1104","description":"CWE-1104: Use of Unmaintained Third Party Components","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"VulnCheck","orgId":"83251b91-4cc7-4094-a5c7-464a1b83ea10","dateUpdated":"2026-05-15T11:15:12.535Z"},"cpeApplicability":[{"operator":"OR","nodes":[{"operator":"OR","negate":false,"cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:vasion:virtual_appliance_host:*:*:*:*:*:*:*:*","versionEndExcluding":"22.0.893"}]}]},{"operator":"OR","nodes":[{"operator":"OR","negate":false,"cpeMatch":[{"vulnerable":true,"criteria":"cpe:2.3:a:vasion:virtual_appliance_application:*:*:*:*:*:*:*:*","versionEndExcluding":"20.0.2140"}]}]}],"credits":[{"lang":"en","type":"finder","value":"Pierre Barre"}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"vulncheck"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-19T20:02:09.169453Z","id":"CVE-2025-34192","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-09-19T20:02:24.580Z"}}]}}}