{"id":"CVE-2025-33142","state":"PUBLISHED","title":"IBM WebSphere Application Server information disclosure","description":"IBM WebSphere Application Server 8.5 and 9.0 could provide weaker than expected security for TLS connections.","publishedAt":"2025-08-14T15:41:59.719Z","updatedAt":"2025-08-14T19:55:56.651Z","severity":{"score":5.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N","source":"ibm"},"assigner":"ibm","products":["IBM WebSphere Application Server"],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","defaultStatus":"unaffected","versions":[{"version":"8.5","status":"affected"},{"version":"9.0","status":"affected"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:8.5:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*"]}],"references":["https://www.ibm.com/support/pages/node/7242172"],"weaknesses":["CWE-295"],"ingestedAt":"2026-10-29T20:09:03.054Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/33xxx/CVE-2025-33142.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-33142","state":"PUBLISHED","datePublished":"2025-08-14T15:41:59.719Z","dateUpdated":"2025-08-14T19:55:56.651Z","assignerShortName":"ibm","assignerOrgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateReserved":"2025-04-15T17:51:21.700Z"},"containers":{"cna":{"title":"IBM WebSphere Application Server information disclosure","descriptions":[{"lang":"en","value":"IBM WebSphere Application Server 8.5 and 9.0 could provide weaker than expected security for TLS connections."}],"affected":[{"vendor":"IBM","product":"WebSphere Application Server","defaultStatus":"unaffected","versions":[{"version":"8.5","status":"affected"},{"version":"9.0","status":"affected"}],"cpes":["cpe:2.3:a:ibm:websphere_application_server:8.5:*:*:*:*:*:*:*","cpe:2.3:a:ibm:websphere_application_server:9.0:*:*:*:*:*:*:*"]}],"references":[{"url":"https://www.ibm.com/support/pages/node/7242172","tags":["vendor-advisory","patch"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.3,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-295","description":"CWE-295 Improper Certificate Validation","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"ibm","orgId":"9a959283-ebb5-44b6-b705-dcc2bbced522","dateUpdated":"2025-08-14T15:41:59.719Z"},"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH66167.<br><br>For IBM WebSphere Application Server traditional:<br><br>For V9.0.0.0 through 9.0.5.24:<br>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH66167 <br>--OR--<br>· Apply Fix Pack 9.0.5.25 or later (targeted availability 3Q2025). <br><br>For V8.5.0.0 through 8.5.5.28:<br>· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH66167 <br>--OR--<br>· Apply Fix Pack 8.5.5.29 or later (targeted availability 1Q2026). <br><br> <br><br>Additional interim fixes may be available and linked off the interim fix download page."}],"value":"IBM strongly recommends addressing the vulnerability now by applying a currently available interim fix or fix pack that contains the fix for APAR PH66167.\n\nFor IBM WebSphere Application Server traditional:\n\nFor V9.0.0.0 through 9.0.5.24:\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH66167 \n--OR--\n· Apply Fix Pack 9.0.5.25 or later (targeted availability 3Q2025). \n\nFor V8.5.0.0 through 8.5.5.28:\n· Upgrade to minimal fix pack levels as required by the interim fix and then apply the Interim Fix that resolves PH66167 \n--OR--\n· Apply Fix Pack 8.5.5.29 or later (targeted availability 1Q2026). \n\n \n\nAdditional interim fixes may be available and linked off the interim fix download page."}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-08-14T18:43:47.574878Z","id":"CVE-2025-33142","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-08-14T19:55:56.651Z"}}]}}}